The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim started refusing passwords?

Discussion in 'General Discussion' started by Xenon101, Oct 9, 2005.

  1. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Just yesterday (nothing has changed) exim has started refusing pop3 logins (but i can get into port 2095, not tried accessing mail there). It's happening in outlook, ive tried changing my pop3 password but still cant get into it.

    I'm server admin so can do anything to it, have fried /scripts/eximup --force with no luck any ideas?

    Edit: webmail lets me login, what the hell is going on here? is it something with cppop?
     
  2. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    Are you on a VPS (Virtual Private server)?
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    exim has nothing to do with pop logins. That is handled by the pop server. You have one of 2 choices now. For many years cppop (a cpanel based pop server) did all the pop sessions on the box. In the last few days a conversion to maildir from mbox has been made available in a effort to get away from a security flaw in the imap server we have been running. This conversion basically converts all your users mail inbox files to maildir format and removes the cppop pop deamon and installs courier which handles pop and imap I believe ..all in one now. If someone using WHM clicked the conversion script link in WHM at the top page it is possible that the conversion could run for hours and hours if the mail file sizes were large on the box. It's also possible that something went wrong in the install for the new courier. If you are 100% sure that the conversion has not been started then you have other reasons for cppop to reject passwords. An inbox.lock file (per account) would cause this as well. If every email box is getting this problem then it's most likely your maildir conversion is either still running or got screwed up somehow. pop sessions don't rely on exim so I think you can rule that out for now.

    this thread might help also.
    http://forums.cpanel.net/showthread.php?t=44926
     
    #3 rpmws, Oct 9, 2005
    Last edited: Oct 9, 2005
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You should also check your /var/log/maillog file when you attempt to POP the account to see what errors/messages appear.
     
  5. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    I am on a vps, yes.

    I'm not sure that theres anything wrong in the maillog?

    Code:
    Oct  9 13:51:59 vps imapd[2041]: Authenticated user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Oct  9 13:51:59 vps imapd[2041]: Logout user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Oct  9 13:52:02 vps imapd[2068]: Authenticated user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Oct  9 13:52:03 vps imapd[2068]: Logout user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Oct  9 13:52:09 vps imapd[2248]: Authenticated user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Oct  9 13:52:10 vps imapd[2248]: Logout user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Oct  9 13:53:37 vps imapd[2287]: Authenticated user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Oct  9 13:53:38 vps imapd[2287]: Logout user=iain.shortreed domain=xn3.net host=localhost [127.0.0.1]
    Edit: unless a reseller could have clicked the update script it's not possible that's whats happened.
     
  6. Xenon101

    Xenon101 Well-Known Member

    Joined:
    Mar 13, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    I've just done a clean install and i'm still having the same problem!!! How the heck is that possible? I've verified it isn't just me by getting other users of the xn3.net domain to try and login with no luck. Has pop3 been set to only allow localhost logins or something? I'm totally stumped!

    Would converting to maildir fix this problem? Because at present i could drop all accounts and convert without a problem if it would be better than having to do it later.

    Edit: I converted to maildir, still having the same problem. Nothing is being added to /var/log/maillog however? Very confused as to why it's doing this :confused:
     
    #6 Xenon101, Oct 9, 2005
    Last edited: Oct 9, 2005
  7. dreamwiz

    dreamwiz Well-Known Member

    Joined:
    Aug 28, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6

    Same problem here :(
     
  8. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
  9. dreamwiz

    dreamwiz Well-Known Member

    Joined:
    Aug 28, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
Loading...

Share This Page