The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim started to slow down sending and delivering

Discussion in 'General Discussion' started by kevinlevin, Jan 14, 2013.

  1. kevinlevin

    kevinlevin Member

    Joined:
    Oct 27, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all,

    Approx. 24 hours ago Exim began to slow down the mails.
    It takes 2-3 minutes to send an email or to deliver one.
    I can see the mail in the mail queue but it has been hold there and after 2-3 minutes - released.
    I have checked the mail queue, reset the exim configuration to defaults, checked for network issues, restarted exim, restarted dns server, checked the server load... but none of these actions fixed the problem.

    When I make exigrep with a mail_id, everything looks just normal ("SMTP connection outbound") and no errors are found.

    It seems like Exim started to behave this way from nothing.

    Can someone help here?
     
  2. SB-Nick

    SB-Nick Well-Known Member

    Joined:
    Aug 26, 2008
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi kevinlevin,

    Try watching a "tail -f /var/log/exim_mainlog" while there are emails going out and see if there is any error between the STMP connection and the mail delivery.
    I would also recommend to check the server nameservers in /etc/resolv.conf and test if they are replying MX records fast.
     
  3. kevinlevin

    kevinlevin Member

    Joined:
    Oct 27, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator

    Hey, thank you for your answer.
    The mainlog gives me just SMTP connection outbound and after 2-3 minutes the message is sent. No errors or whatsoever..

    How I can check if the nameservers replying fast?

    Btw, I have also noticed that some sites with .htaccess files with allow/deny IP rules started to behave slow too. I don't know if this is related.
     
    #3 kevinlevin, Jan 15, 2013
    Last edited: Jan 15, 2013
  4. SB-Nick

    SB-Nick Well-Known Member

    Joined:
    Aug 26, 2008
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hello,

    You can test it by issuing the following command,

    # host -tMX domain.tld

    where "domain.tld" is the remote domain you want to test.

    I would also try telnetting domain.tld to port 25 and see if you are getting the SMTP banner fast as well, you can do this by typing the following command,

    # telnet domain.tld 25

    If all the above goes through fine then something within exim may be causing the issue and it will require further troubleshoot.
     
  5. m0rpheu5

    m0rpheu5 Well-Known Member

    Joined:
    Jun 16, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil, Curitiba/PR
    cPanel Access Level:
    Root Administrator
    Same problem here, the server is normal, but sometime the queue start to get 50, 100, 200, 300 emaisl on the queue, 80% for local queue, so i run the exim -q or on the configserver mail queue i click to run, and the messages go away with no problem, but why the message is get stopped on the queue?

    Thanks
     
  6. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    10
    Trophy Points:
    18
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    In CMQ, list the queue, then click "View Deliver Log" (the clock icon) and you might see the reason why it's delayed.
     
  7. m0rpheu5

    m0rpheu5 Well-Known Member

    Joined:
    Jun 16, 2005
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brazil, Curitiba/PR
    cPanel Access Level:
    Root Administrator
    i got this.

    2013-01-18 16:50:52 1TwH0W-0005qm-Ly no immediate delivery: load average 38.77
    2013-01-18 16:50:34 1TwGzn-0005pF-Aw no immediate delivery: load average 36.32
    2013-01-18 16:50:46 1TwGzl-0005pI-Hf no immediate delivery: load average 39.19
    2013-01-18 16:50:39 1TwGyl-0005aD-3F no immediate delivery: load average 38.62

    my load average is really right, but this happens when the queue start to grow up, or is something that i´m not locating what is using so much resources.

    Thanks
     
  8. SB-Nick

    SB-Nick Well-Known Member

    Joined:
    Aug 26, 2008
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I would recommend setting up a load alert email notification with a 5min period to something like a "10.0" load avg value and access the server once you receive it, setting up a mail queue alert would also help, set it to something to alert you if the mail queue goes higher than 30 emails stuck on queue.

    - Go to Home »Server Status »Apache Status in WHM and see if Apache isnt overloading your server.
    - Run "tail -f /var/log/exim_mainlog" and see if no one is spamming through your server.
    - Run "top" or go to Home »System Health »Process Manager and see which process are on the top of the list

    I would start by doing this, it could be anything, from a spammer to cronjob or a email looping.
     
  9. lunix8x

    lunix8x Registered

    Joined:
    Jan 22, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    i don't think it
     
Loading...

Share This Page