The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim stop putting Received: header

Discussion in 'General Discussion' started by spector, Jan 11, 2006.

  1. spector

    spector Well-Known Member

    Joined:
    Jun 27, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I dont think I'll ever get an answer, but it might be worth asking.

    How sould I make my smtp server (exim) stop putting Recived: header into emails that I send. Recived: headers reveal IP of the sender. It would be ok if I could stop insertion of thease headers for specified domains in From: or maybe for specified IP of senders.


    perhaps someone can recomend linux smtp server that is not inserting Recived: hearers into email.
     
    #1 spector, Jan 11, 2006
    Last edited: Jan 11, 2006
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You can do that by adding the following to the first textarea of the exim configuration editor:

    received_header_text = ""

    Be aware that you are breaking the SMTP RFC's by doing so, though.
     
  3. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Doing that is a really bad idea. It will prevent automated email loop checking for one thing, which may mean a single looping email may have the ability to completely disable your server; for another thing it will break the ability for people to diagnose email problems.

    If you need completely confidential email (why?) there are various secret emailers around.
     
Loading...

Share This Page