Exim The account or domain may not exist, they may be blacklisted, or missing the proper dns entries

Nick Dragomir

Registered
Jul 16, 2016
3
0
1
Brasov, Romania
cPanel Access Level
Root Administrator
Hello,

I have read and tried every single suggestion within the forums with no avail.

I have the domain name: domain.com setup under user: doman.

The system hostname is mail.domain.com.

The domain MX setup is correct. On a dig mx domain.com it returns the proper entry.
The A record for the mail.domain.com points to the actual machine. PTR is also set up.

I have tried setting up MX as both "Automatically Detect Configuration" and "Local Mail Exchanger" with no avail.

I have verified and made sure permissions are correctly set up.

I have added e-mail accounts from cPanel.

On sending e-mails from one of the e-mail addresses locally set up I get the error:

Code:
The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
On sending e-mails from a different e-mail address to a locally set up e-mail address I get:

Code:
550-Verification failed for <[email protected]>
550-The mail server could not deliver mail to [email protected]  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
550 Sender verify failed
It would seem that the mailing system is behaving as if any e-mail is local regardless of whether it sends or receives e-mails.

Please help!

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
The system hostname is mail.domain.com.
Hello,

This stands out as a potential issue. Are you also using "mail.domain.com" as as subdomain on the "domain.com" cPanel account? If so, that could lead to a potential conflict. Try updating the hostname to "server.domain.com" temporarily to see if that makes a difference. Also, could you let us know the output from a command such as "exigrep [email protected] /var/log/exim_mainlog" so we can get a better idea of how Exim is treating the message?

Thanks!
 

Nick Dragomir

Registered
Jul 16, 2016
3
0
1
Brasov, Romania
cPanel Access Level
Root Administrator
Hello,

This stands out as a potential issue. Are you also using "mail.domain.com" as as subdomain on the "domain.com" cPanel account? If so, that could lead to a potential conflict. Try updating the hostname to "server.domain.com" temporarily to see if that makes a difference. Also, could you let us know the output from a command such as "exigrep [email protected] /var/log/exim_mainlog" so we can get a better idea of how Exim is treating the message?

Thanks!
Hi Michael,

Thank you for replying.

I have tried changing the /etc/hostname in all various ways; from admin to mail.domain.com to domain.com. Nothing works.

I do not have the domain.com MX set as a subdomain within domain.com.

This is the output:

Code:
exigrep [email protected] /var/log/exim_mainlog
2016-07-25 14:35:25 1bRf6T-0003TS-Qu <= [email protected] H=(vmi73563.provider.host) [::1]:47792 P=esmtpa A=dovecot_login:[email protected] S=565 [email protected] T="Test" for [email protected]
2016-07-25 14:35:25 1bRf6T-0003TS-Qu SMTP connection outbound 1469450125 1bRf6T-0003TS-Qu domain.com [email protected]
2016-07-25 14:35:25 1bRf6T-0003TS-Qu ** [email protected] R=fail_remote_domains: The mail server could not deliver mail to [email protected]  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.
2016-07-25 14:35:25 1bRf6T-0003TS-Qu Completed

2016-07-25 16:07:12 H=mail-wm0-f48.google.com [74.125.82.48]:37073 sender verify fail for <[email protected]>: The mail server could not deliver mail to [email protected]  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.

2016-07-25 16:07:12 H=mail-wm0-f48.google.com [74.125.82.48]:37073 X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no F=<[email protected]> rejected RCPT <[email protected]>: Sender verify failed
I have changed the actual hosts and e-mail addresses to respect the client's privacy.

Thank you in advance!

Nick
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

Thank you.