The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim the killer

Discussion in 'E-mail Discussions' started by j0hnny, Sep 8, 2009.

  1. j0hnny

    j0hnny Registered

    Joined:
    Sep 8, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have 2 questions, I've been doing a lot of search but can't figure out exactly how to do it.

    1. I'm trying to configure exim (via cPanel) to reject the unknown users without queueing them beecause it's causing a lot of troubles.

    2. Any idea why exim keeps message over 1 month old in queue? Are there some particular settings which need to be configured for the messages to be returned or discarded after a few days?! (like it normally should!)

    Thanks a lot.

    PS to cPanel developers: Will you ever start using a real MTA and switch to Postfix?!
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Exim is a great MTA. Very very flexible. I can't think of a single complaint. Everyone has their opinion, but I don't know many people personally who have the opinion that Postfix is so much better than Exim :)

    Make sure the catchall (default) address for all of your email accounts is set to Fail (rather than Blackhole).

    WHM / Exim Configuration Editor
    - under the Mail section:

    Default catch-all/default address behavior for new accounts. "fail" is usually the best choice if you are getting mail attacks.

    Set it to Fail

    If you do this, NEW accounts that are set up will have the catchall account set to Fail - which will reject incoming mail to unknown users for that domain.

    For existing domains, you must either log into each cPanel account's /cpanel interface and set their default address to Fail, or you can go into /etc/valiases/* and change the catchall account (which is *:) to something like:

    *: :fail: No such user here


    Also, don't use the "Filters" IN Exim Configuration Editor to reject spam - The "filters" will accept / bounce spam. You want to use the "ACLs" to reject spam.

    For instance, I like to reject any mail with a spam score greater than 12.5 - So under the ACL section of Exim Configuration Editor, I checkmark the following:

    SpamAssassinTM: Reject mail with a spam score greater than 12.5 at SMTP time. [?]

    Mike
     
  3. j0hnny

    j0hnny Registered

    Joined:
    Sep 8, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks a lot for your reply but it didn't quite help much.

    My default policy is set to Fail already also there is no catch-all configured for any of the domains.

    I believe exim is already configured to use ACLs. I already disabled both clamav and spamassassin as I don't need any of those. I just checked that spamassassin setting you mentioned but I doubt that will help.

    Any other suggestions?

    Thanks.
     
  4. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    1. I have no idea why your Exim is keep mails in the queue for a month. Default configuration doesnt' do that, and mine doesn't do that.

    I have to assume you've made some changes. Perhaps you should restore all Exim settings back to default by going into WHM / Exim Configuration Editor, going to the bottom and telling it to restore everything to default.

    Then start from scratch.

    2. If Exim isn't rejecting for nonexistent users, you've reconfigured it or fouled up some settings somewhere.

    Restore Exim to default config in the WHM Configuration Editor, make sure that Tweak Settings has it set to create new domains with :fail. Make sure all of your accounts _have_ a default address set and that the default address is set to fail.

    It really can't get much easier. So if you're having problems, you need to start with restoring things to default and then going back through and configuring through the Exim Configuration Editor to suit your tastes.

    Mike
     
  5. bigolo

    bigolo Member

    Joined:
    Dec 5, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Exactly my point, why does my MTA have to be like my Windows OS? When something's very wrong and can't figure out why just restore/reinstall from scratch?!?

    I can't do a complete restore, this is a live server and I didn't configure it initally, I'm just trying to fix some problems. Restoring all the settings might cause other problems which I don't need.

    I thought there might some setting which changes the default behavior to make exim verify the recipient when it receives the RCPT TO command. I guess I'll have to dig some more.

    If anyone else got any ideas, I'd really appreciate it.

    Thanks a lot for your help.
     
  6. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    How can this be your point as this is your initial foray into this thread?

    Mike was suggesting restoring Exim to the default configuration. Starting from a minimal configuration is a basic troubleshooting technique, especially when one is working with an unfamiliar system. There's no reason to dramatize it.

    Please open a support ticket at https://tickets.cpanel.net/submit/ and our support techs will gladly help you resolve the issue.
     
  7. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    I have a feeling somebody [perhaps you, perhaps not] initially either:

    1. Went into Exim Configuraiton Editor and customized it to your liking

    OR

    2. Manually edited Exim configuration files

    I'm saying to make note of ALL of the current settings that you have in Exim Configuration Editor. Then go down to the bottom of the Exim Configuration Editor and restore to defaults.

    You aren't uninstalling/reinstalling anything. It'll take 5-10 minutes to put back in the necessary changes that you need in there. But somewhere along the line you or somebody else most likely edited something in the Exim Configuration Editor. that is the only explanation I have.

    Otherwise, if a person simply installs Cpanel, goes in to Tweak Settings and sets the default behavior for the catchall to be :FAIL, and then makes sure that any domains that are added (a) have a catchall set and (b) have the catchall default address set to :* :fail: some_description, then Exim IS going to reject messages to nonexistent recipients.

    I'll really be interested in suggestions that others may have.

    Mike
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,474
    Likes Received:
    202
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I think you've covered it, Mike. ;)
     
  9. bigolo

    bigolo Member

    Joined:
    Dec 5, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Thank you all for your replies. I really don't want to start an endless discussion over which MTA is better but for one exim documentation is not great.

    Now referring to my problems, I managed to figure out issue number 1, apparently the ip address of the remote server was whitelist and that caused to exim to override any recipients checks. I was testing from localhost (127.0.0.1) which was not listed as whitelisted though and still didn't get a reject but that's not the point of this thread.

    Anyway, in case someone else gets to this thread looking for an answer, you need to go to:

    Main > Service Configuration > Exim Configuration Editor and edit the following two lists:

    ** Whitelist: Bypass all SMTP time recipient/sender/spam/relay checks
    Whitelist: Trusted Mail Hosts/IP Blocks (bypass all SMTP time checks except recipient verification)

    Removing the whitelisted address from ONLY one of the two will not get the server to reject unknown user (another strange behavior).

    Referring to my second issue, I still need help in figuring out why I found about 1.5 million emails in the queue which were over 1 month old. I checked the settings which considered to be referring to this matter and look ok, but still exim doesn't seem to return the email or discard them. Any idea on where I should check?

    Thanks.
     
  10. bigolo

    bigolo Member

    Joined:
    Dec 5, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Looks like I already had an account on this forum created a while ago, sorry about that (both j0hnny and bigolo are my own posts).

    Thanks.
     
Loading...

Share This Page