The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim - Time hold in queue

Discussion in 'General Discussion' started by sergio2004, Jun 26, 2004.

  1. sergio2004

    sergio2004 Well-Known Member

    Joined:
    Feb 28, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro
    Hi,

    I would like reduce the time of messages holding in the queue when the mailbox is full or the message is reject by the other server. I want the message back to sender in 3 hs for the sender know the people don`t receive the email message.

    I have root access and I edit the exim.conf like below.

    The default was:

    #!!# ignore_errmsg_errors_after renamed ignore_bounce_errors_after
    ignore_bounce_errors_after = 2d

    # This option cancels (removes) frozen messages that are older than a week.

    timeout_frozen_after = 7d

    I change to:

    #!!# ignore_errmsg_errors_after renamed ignore_bounce_errors_after
    ignore_bounce_errors_after = 1d

    # This option cancels (removes) frozen messages that are older than a week.

    timeout_frozen_after = 2d


    The default was:
    In the RETRY CONFIGURATION (in the end of file)

    F,2h,15m; G,16h,1h,1.5; F,4d,8h

    I change to:

    In the RETRY CONFIGURATION (in the end of file)

    F,1h,15m; G,2h,1h,1.5; F,1d,3h


    Is these changes correct? Because I send a test message for one account that is full and the message is in the queue have 23 hs. holding...

    How can I set these values or the exim.conf for back delivery email to sender with the message that mailbox is full or the message was reject?

    Thank you.
     
  2. amal

    amal Well-Known Member

    Joined:
    Nov 22, 2003
    Messages:
    155
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Did u restart the exim service

    Hi,

    The changes that you made are correct. Did you restart exim after you made the changes? If not, do it. It'll work fine for you.

    Amal.
     
  3. sergio2004

    sergio2004 Well-Known Member

    Joined:
    Feb 28, 2004
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro
    Hi,

    Thank you for your anwser.

    I restart the exim but i would like the email message return (back) to sender after 3 hs if the mailbox is full or reject.

    Thank you
     
Loading...

Share This Page