The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

EXIM + TLS timeout problems

Discussion in 'General Discussion' started by ninja_byte, Jun 1, 2004.

  1. ninja_byte

    ninja_byte Member

    Joined:
    May 6, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    EXIM + TLS problems

    Ok, we've got several servers that are fouling up recently at the company I work for.

    Basically exim is hanging indefinately after the STARTTLS smtp command. This has been verified on several hosts, and followed a recent mass-update of cpanel

    On the example host:
    Exim 3.36
    Linux 2.4.x
    WHM 9.2.0 cPanel 9.2.0-S25
    RedHat 7.2 - WHM X v2.1.2

    A few elementary attempts have been made to stop TLS from starting alltogether, but to no avail. The /etc/exim.conf entries that specifies all the TLS information has been commented out, but when the foreign host advertises the TLS service, the server starts the handshake no matter what. A verbose mail test verified all this, and will follow.

    My questions:
    1. How can I completely stop TLS connections from being started(other than commenting out the exim.conf entries)?
    2. If commenting these out is the only way, do I need to take special steps afterwards(or startup flags/arguments) to force exim to follow these guidelines?
    3. Any ideas on what the root cause of this issue is? Some possibilities would be
    invalid certificate
    bad openSSL version
    missing certificate
    bad luck in general

    Please point me in the right direction...

    ####start mail test output####
    host20:~#echo "test"|mail -v adziwulski@wp.pl
    LOG: 0 MAIN
    <= root@host20.xxx.xxx U=root P=local S=303
    delivering message 1BVMsp-0002uH-00
    host20:~#Connecting to smtp.wp.pl [212.77.101.160.25] ... connected
    SMTP<< 220 smtp.wp.pl ESMTP
    SMTP>> EHLO host20.xxx.xxx
    SMTP<< 250-smtp.wp.pl
    250-PIPELINING
    250-AUTH=LOGIN PLAIN
    250-AUTH LOGIN PLAIN
    250-STARTTLS
    250-SIZE
    250-X-RCPTLIMIT 100
    250 8BITMIME
    SMTP>> STARTTLS
    SMTP<< 220 ready for tls
    Initialised TLS (OpenSSL/0.9.5beta)

    #and now it hangs indefinately
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I can't really answer your main questions, but did spot this:
    Is there any particular reason that you're not running Exim 4.34 which is the latest cPanel offering?
     
Loading...

Share This Page