The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim: two "strange?" questions...

Discussion in 'General Discussion' started by cYbErDaRk, Mar 21, 2005.

  1. cYbErDaRk

    cYbErDaRk Member

    Joined:
    Jan 9, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Madrid - Europe
    Hi everybody.

    I've been looking around the forum for the answer to this questions and didn't find anything... let's see if someone can help me :(

    Every Sunday I have the same problem with exim, after (it seems) doing the backups of all the accounts (as it must do it on Sundays). Email users are unable to send their messages, it says the typical response about the need of loggining first (SPAM protection activated). But, after doing that, you're unable to send anything, it says the same.

    What I've noticed is the fact that syslogd gets frozen (FW, tail -f /var/log/maillog does not produce any ouput), every Sunday. Just restarting exim and syslogd solves the problem.

    Does anyway know where should I start to search? I has no sense to me...

    Second problem is really quite strange... has someone seen how an email account gets lost? simply dissapears? Just sometimes, but it cannot explain why... all emails are ok but passwd file (/home/account/etc/domain/passwd) lacks of one line, the one for that user.

    I'm using PIV, FC2, lastest release.

    Thanks in advance (really), and sorry for my English.

    David
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Hi David,

    First off, what version of cPanel are you running (there were some issues with accounts disappearing from the passwd files some time ago)?

    Secondly, I would guess that the problem with exim/syslog would be down to logrotate. I notice that you're running FC2 - have you by any chance secured /tmp by using /scripts/securetmp?

    If so, you need to check /etc/cron.daily/ and/or /etc/cron.weekly/ for a job that runs logrotate. Edit the file(s) add the following lines after the first line of the script:

    TMPDIR=/mytmp
    export TMPDIR


    Then create that directory:

    mkdir /mytmp

    You can then try running the script(s) that you edit to see if all goes well, and/or report back in a week.
     
  3. cYbErDaRk

    cYbErDaRk Member

    Joined:
    Jan 9, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Madrid - Europe
    Hi chirpy

    WHM 10.0.0 cPanel 10.0.0-C152
    Fedora i686 - WHM X v3.1.0

    By hand, in fact (think you mean this, sorry for my English):

    /dev/tmpMnt /tmp ext2 loop,noexec,nosuid,rw 0 0

    It's ok to set it to /tmp? (logrotate runs weekly)

    I've changed that. I'll report next sunday.

    Thanks a lot! (really)

    PS: I've also problems doing backups (high load)... but I've seen so many posts about the topic that I don't dare... :)
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Hi,

    The reason for adding the TMPDIR parameter (you must not set TMPDIR to use /tmp you need to create a new directory called something like /mytmp with mkdir /mytmp) is that there is a bug in Fedora 1/2 (don't know about 3) whereby logrotate fails if you have noexec set on your /tmp directory. This doesn't affect any other Linux distros as far as I know.
     
  5. cYbErDaRk

    cYbErDaRk Member

    Joined:
    Jan 9, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Madrid - Europe
    Thanks a lot :)
     
Loading...

Share This Page