The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim (unrouteable mail domain)

Discussion in 'E-mail Discussions' started by xploit, Jul 19, 2004.

  1. xploit

    xploit Member

    Joined:
    Jul 17, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    my server has been working fine,i just updated lately to :
    WHM 9.4.0 cPanel 9.4.1-S65
    RedHat Enterprise 3 - WHM X v3.1.0

    two days later,a user with xxx.yyy.com at my server reported that whenever he sends an email to yy@china-inse.com he get this error:

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    yy@china-inse.com
    unrouteable mail domain "china-inse.com"

    when i dig for the MX records for this domain from my server,it resolves.

    when i check from the ssh using : /usr/sbin/exim -bt -d inse@china-inse.com
    i get the following :
    Code:
    Exim version 4.34 uid=0 gid=0 pid=23956 D=fbb95cfd
    Berkeley DB: Sleepycat Software: Berkeley DB 4.1.25: (August 21, 2003)
    Support for: iconv() PAM Perl OpenSSL
    Lookups: lsearch wildlsearch nwildlsearch iplsearch dbm dbmnz
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile autoreply pipe smtp
    changed uid/gid: forcing real = effective
      uid=0 gid=0 pid=23956
      auxiliary group list: <none>
    configuration file is /etc/exim.conf
    log selectors = 00000ffc 00010400
    trusted user
    admin user
    originator: uid=0 gid=0 login=root name=root
    sender address = root@mercury.xool.net
    Address testing: uid=0 gid=12 euid=0 egid=12
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    Testing inse@china-inse.com
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    Considering inse@china-inse.com
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    routing yy@china-inse.com
    --------> defer_router router <--------
    local_part=yy domain=china-inse.com
    calling defer_router router
    rda_interpret (string): :defer: All deliveries are handled by MailScanner
    expanded: :defer: All deliveries are handled by MailScanner
    file is not a filter file
    parse_forward_list: :defer: All deliveries are handled by MailScanner
    extract item: :defer: All deliveries are handled by MailScanner
    defer_router router: defer for yy@china-inse.com
      message: All deliveries are handled by MailScanner
    yy@china-inse.com cannot be resolved at this time:
      All deliveries are handled by MailScanner
    search_tidyup called
    >>>>>>>>>>>>>>>> Exim pid=23956 terminating with rc=1 >>>>>>>>>>>>>>>>
    
    everything is working fine with me.except this domain.
    exim log files gives me no clues at all.

    any ideas ?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    All the exim output you quoted shows is that mail delivery is handled by MailScanner, so is not at all helpful. However, this:
    is not coming from your server, but from the one at the end of china-inse.com, and indicates a problem on that server, not yours. The message would indicate that the remote server has not been setup to relay email for that domain.
     
  3. xploit

    xploit Member

    Joined:
    Jul 17, 2004
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    ok,the strange thing is that i can send from the web without problems,and no mails are returned.
    however,when i send using the outlook it returns with the email msg above.

    and please notice,sending by outlook is the one with the problem,not with webmail!

    so any ideas please !
     
Loading...

Share This Page