The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim Unrouteable Problem

Discussion in 'General Discussion' started by Mysteerie, Feb 23, 2005.

  1. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    I’m having a problem with exim and the following:

    Code:
      mysteerie@gmail.com
        unrouteable mail domain "gmail.com"
    I know that there is a lot of topics on this already, and I’m still searching through them for answers. I just need some specific help.

    The server that is going through this problem is a second server, and the main domain isn’t on the second server.

    So I just only added the hostname.mydomain.ext, ns3.mydomain.ext, and ns4.mydomain.ext to the DNS in both this server and the other server.

    Now everything works fine (as their site loads, but could the mail issue be a result of this also, the main domain not being on the server itself).

    I kind of need help tracking this one down, since I don’t want to screw things up further then they are already. Any advice or commands I can run that would help me track where this problem is originating (whether it be DNS, or just my settings)?

    Also as far as I can tell, the only problem is happening when a php script (including cpanel), sends out email. So if a user using pop and smtp they are fine (but not sure).
     
  2. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    I have a similar error but best I got from Cpanel was to turn off verify in exim settings.

    It's not a fix in my opinion but it allows the mail to go through.

    Vin
     
  3. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Turning the verify is nothing more than a hack in my opinion. You need to figure out why its failing.

    usually returns some information.. also are you able to

     
  4. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    Yes I agree but this is the word from Cpanel - turn off the verify setting.

    I tried several things and came up blank.

    Will try to dig more into it but I notice it fails the server name.
    Why is the question since testing it using host -t mx domain_name
    from either server comes up fine.

    In my case it can send mail fine from server A to server B
    But server B could not send to A
    Both servers are up to date on everything.
    The Exim files are identical

    Server B is is running on Centos and server A is running Red Hat 9

    Vin
     
  5. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    Found out the problem is a reverse dns lookup is needed on every domain using a dedicated IP.

    Exim does a reverse lookup and if it fails your message will bounce.

    Since this was a new server it was over looked.

    Vin
     
  6. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    Back to Square one

    Setup the reverse for all and still the same
    Begining to think it's an OS issue

    One server has Red Hat 9 and the other has Centos

    I checked everything from top to bottom and still get an error if I set the verify sender on on the Red Hat server.

    550-unrouteable mail domain "newage.dns-safe.com"
    550 Sender verify failed

    No test has shown any info that can indentify why newage.dns-safe.com is not passing the exim test.

    Still looking into it.

    vin
     
  7. vincentg

    vincentg Well-Known Member

    Joined:
    May 12, 2004
    Messages:
    140
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    new york
    I fixed it

    Was a bad entry in the DNS for server that was receiving the mail.

    The same domain name is used for both and by mistake we had an entry on the second server that should not have been there.

    Vin
     
Loading...

Share This Page