The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim with upstream spam filter

Discussion in 'E-mail Discussions' started by SPaul, Aug 27, 2015.

  1. SPaul

    SPaul Registered

    Aug 27, 2015
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello, all.

    So, I have the MX records for pointing to spamexperts which points to my server which hosts the domain's mailboxes. All is well except that nefarious spammers ignore MX records and just connect directly to my server's port 25. So, to keep this from happening, I add this as a custom acl_smtp_rcpt:custom_begin_recipient:

    domains =
    !hosts = : localhost
    message = Please deliver mail to the address specified in the MX records for this domain.

    This works great except if a client machine that sends its email through my server (i.e., addressed to another user in the same domain. Even though the zone file on my server for has the proper spamexperts MX entries, they are ignored when sending intra-domain email and, thus, the above custom ACL gets triggered and the email is rejected because such a connection is seen by EXIM not as localhost but, rather, the IP/hostname of the client computer.

    Any ideas other of changing everyone's settings in their email programs?


Share This Page