The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim won't authenticate users without "My server requires authentication" option on.

Discussion in 'General Discussion' started by Cha0s, Jun 7, 2011.

  1. Cha0s

    Cha0s Member

    Mar 9, 2006
    Likes Received:
    Trophy Points:
    Hello guys,

    The last couple of days our cPanel servers started to reject any mails sent from our users (authenticated users)

    It seems that something changed during a cpanel update that made exim to not accept connections from users without the "My server requires authentication" option on their MUA.

    All these years the way it worked was a user was receiving the mails via pop3, and the authentication session made via pop3 it would be used by exim to authenticate a user and send out mails.

    But now exim won't accept this. It needs the credentials to be sent explicitly to exim (thus the "My server requires authentication" option that needs to be enabled).

    Since we are talking about hundreds of users/mail accounts and hundreds of phone calls to our support department, is there a way to revert exim back to the way it was?
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Nov 29, 2006
    Likes Received:
    Trophy Points:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Re: Exim won't authenticate users without "My server requires authentication" option

    The first thing to do to troubleshoot this problem is to run the following in a root shell:

    If you see a permission denied error:

    Run this

    If you see a syntax or other error, you may have installed an incompatible plugin or made a modification to the exim config that doesn't work with the version of cPanel you are running. You can reset your configuration to the default here:

    WHM >> Service Configuration >> Exim Configuration Editor >> (Advanced Button) >> (Reset All Configs Button)

    If that still doesn't work:

    Use the Support Menu in WHM to Contact cPanel, or open a support request here:

Share This Page