The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim wont receive email

Discussion in 'E-mail Discussions' started by deftech, Aug 30, 2006.

  1. deftech

    deftech Member

    Joined:
    Jan 11, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    We had a major problem with exim so we reinstalled it via /scripts/eximup --force

    Now all smtp servers on the net are getting bounced with
    550-(blah-blah.com) [4.18.83.3] is currently not permitted to relay
    550-through this server. Perhaps you have not logged into the pop/imap server
    550-in the last 30 minutes or do not have SMTP Authentication turned on in your
    550 email client.

    Something is amiss, as exim is bouncing all mail, including legit servers. I can't send from my gmail to my work account.

    It's like smtp auth is bouncing everything!

    Please help :)0o
     
  2. kdarray

    kdarray Well-Known Member

    Joined:
    Apr 13, 2006
    Messages:
    81
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Washington
    Try this

    I had a similar issue a few months ago, and this is what worked for me.

    Per Cpanel.

    "Running "rm -f /etc/eximmailtrap" usually resolves errors where the logs say certain UID's or GID's aren't permitted to relay mail. "

    And an addendum from Chirpy:

    Just for posterity of the thread - if this happens you also need to set eximmailtrap=0 in /var/cpanel/cpanel.config as well otherwise then next time you click WHM > Tweak Settings, /etc/eximmailtrap will be recreated.
     
  3. pcgh

    pcgh Active Member

    Joined:
    Jun 25, 2003
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Deftech,

    Did this fix your problem? I have been round and round with virtually the exact same issue. Very intermittent for me. Rejects a message but if the same person sends it again, it goes through. See here for more info:

    http://forums.cpanel.net/showthread.php?t=57028

    Any help would be greatly appreciated!

    Tony
     
  4. vishwas

    vishwas Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Front of PC
    Getting same error

    Hi,

    No eximmailtrap file on server still getting this error, the main thing is when i set user account as :fail: from cpanel the nonexisting mails work properly means they goes to :fail and
    i can see those in

    main@domainname.com
    SMTP error from remote mail server after RCPT TO:< main@domainname.com>:
    host domainname.com [ip.ip.ip.ip]: 550-"The recipient cannot be verified.
    Please check all recipients of this
    550 message to verify they are valid."

    /scrpt/reseteximtodefault also tried no fun :s

    -Any suggetion .......!!
     
  5. r00t pAsSw0rd

    r00t pAsSw0rd Active Member

    Joined:
    Sep 14, 2006
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    same here...
     
  6. xerophyte

    xerophyte Well-Known Member

    Joined:
    Mar 16, 2003
    Messages:
    216
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Canada
    Check your /var/log/maillog and see if it has zero size, if it does you have log rotating problem, the cpanel anti relay program get the ips from the maillog, if the current maillog is zero size or maillog is logged to different files, you will get this error

    if that case restart your syslog with service syslogd restart and restart your exim

    hope that helps
     
  7. vishwas

    vishwas Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Front of PC
    If i dont use :fail: the mails are working fine that means there is no problem with log rotate xerophyte.

    -Thank you
     
  8. pcgh

    pcgh Active Member

    Joined:
    Jun 25, 2003
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Well, I opened a trouble ticket and had cPanel look at it. Unfortunately they weren't able to come up with anything. Running out of ideas...

    Tony
     
  9. hexstar

    hexstar Active Member

    Joined:
    Jun 23, 2004
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Internet
    1) I certainly wouldn't want blah-blah.com relaying mail through my mail server...just look at what it is!


    Welcome to blah-blah.com
    Related Searches

    * Blah Blah
    * Blah
    * Homes for Sale
    * Apartments
    * Dating Services
    * Chat Rooms
    * Airline Tickets
    * Travel Guides
    * Las Vegas
    * Hawaii
    * Used Cars
    * Car Accessories
    * Cellular Accessories
    * Cell Phone Deals
    * Download Ringtones

    Favorite Categories
    Autos

    * Car Insurance
    * Used Cars
    * Auto Repair

    Education

    * Online Education
    * School Loan
    * Home School

    Business

    * E-Commerce
    * Home Business
    * MBA

    Employment

    * Employment Services
    * Work at Home
    * Job Search

    Financial Services

    * Debt Consolidation
    * Credit Cards
    * Mortgage

    Entertainment

    * Television
    * Music
    * MP3

    Health

    * Medical Insurance
    * Weight Loss
    * Diet

    Home

    * Home Security
    * Refinancing
    * Real Estate

    Lifestyle

    * Personals
    * Fitness
    * Pets

    Shopping

    * Electronics
    * Flowers
    * Gifts

    Technology

    * Web Hosting
    * Computers
    * Laptops

    Travel

    * Car Rental
    * Airlines
    * Hotels

    Search the Web:


    CTRL-D to Bookmark This Page | Drag This Link To Your Home Button
    © 2006 MDNH, Inc.


    also, blah-blah.com doesn't resolve to 4.18.83.3, it resolves to 66.116.125.121 so I'd verify your dns settings... :)
     
  10. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    check the domainname entry in the file /etc/localdomains
     
  11. Manuel_accu

    Manuel_accu Well-Known Member

    Joined:
    Jun 19, 2005
    Messages:
    191
    Likes Received:
    0
    Trophy Points:
    16
    you can remove it from /etc/remotedomains and add it to /etc/localdomains
     
  12. pcgh

    pcgh Active Member

    Joined:
    Jun 25, 2003
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    I FIXED MINE! :)

    I tried everything I could think of and then on a whim I removed everything out of my exim.conf that had been manually added in the past - specifically the ACL section. With that removed, there were no more false "relay" messages!

    So, I went back and recreated the ACL section from scratch (using http://www.webhostgear.com/175.html as a starting point). After that, things were back to normal.

    I haven't touched exim.conf in a very, very long time so I figure a cPanel update might have messed things up. Anyway, hopefully this helps someone else.

    Tony
     
Loading...

Share This Page