exim wont receive email

deftech

Member
Jan 11, 2006
12
0
151
We had a major problem with exim so we reinstalled it via /scripts/eximup --force

Now all smtp servers on the net are getting bounced with
550-(blah-blah.com) [4.18.83.3] is currently not permitted to relay
550-through this server. Perhaps you have not logged into the pop/imap server
550-in the last 30 minutes or do not have SMTP Authentication turned on in your
550 email client.

Something is amiss, as exim is bouncing all mail, including legit servers. I can't send from my gmail to my work account.

It's like smtp auth is bouncing everything!

Please help :)0o
 

kdarray

Well-Known Member
Apr 13, 2006
81
0
156
Washington
Try this

I had a similar issue a few months ago, and this is what worked for me.

Per Cpanel.

"Running "rm -f /etc/eximmailtrap" usually resolves errors where the logs say certain UID's or GID's aren't permitted to relay mail. "

And an addendum from Chirpy:

Just for posterity of the thread - if this happens you also need to set eximmailtrap=0 in /var/cpanel/cpanel.config as well otherwise then next time you click WHM > Tweak Settings, /etc/eximmailtrap will be recreated.
 

pcgh

Active Member
Jun 25, 2003
43
0
156
Deftech,

Did this fix your problem? I have been round and round with virtually the exact same issue. Very intermittent for me. Rejects a message but if the same person sends it again, it goes through. See here for more info:

http://forums.cpanel.net/showthread.php?t=57028

Any help would be greatly appreciated!

Tony
 

vishwas

Well-Known Member
Feb 9, 2004
61
0
156
Front of PC
Getting same error

Hi,

No eximmailtrap file on server still getting this error, the main thing is when i set user account as :fail: from cpanel the nonexisting mails work properly means they goes to :fail and
i can see those in

[email protected]
SMTP error from remote mail server after RCPT TO:< [email protected]>:
host domainname.com [ip.ip.ip.ip]: 550-"The recipient cannot be verified.
Please check all recipients of this
550 message to verify they are valid."

/scrpt/reseteximtodefault also tried no fun :s

-Any suggetion .......!!
 

xerophyte

Well-Known Member
Mar 16, 2003
216
0
166
Canada
Check your /var/log/maillog and see if it has zero size, if it does you have log rotating problem, the cpanel anti relay program get the ips from the maillog, if the current maillog is zero size or maillog is logged to different files, you will get this error

if that case restart your syslog with service syslogd restart and restart your exim

hope that helps
 

vishwas

Well-Known Member
Feb 9, 2004
61
0
156
Front of PC
Check your /var/log/maillog and see if it has zero size, if it does you have log rotating problem, the cpanel anti relay program get the ips from the maillog, if the current maillog is zero size or maillog is logged to different files, you will get this error

if that case restart your syslog with service syslogd restart and restart your exim

hope that helps
If i dont use :fail: the mails are working fine that means there is no problem with log rotate xerophyte.

-Thank you
 

pcgh

Active Member
Jun 25, 2003
43
0
156
Well, I opened a trouble ticket and had cPanel look at it. Unfortunately they weren't able to come up with anything. Running out of ideas...

Tony
 

hexstar

Active Member
Jun 23, 2004
37
0
156
Internet
1) I certainly wouldn't want blah-blah.com relaying mail through my mail server...just look at what it is!


Welcome to blah-blah.com
Related Searches

* Blah Blah
* Blah
* Homes for Sale
* Apartments
* Dating Services
* Chat Rooms
* Airline Tickets
* Travel Guides
* Las Vegas
* Hawaii
* Used Cars
* Car Accessories
* Cellular Accessories
* Cell Phone Deals
* Download Ringtones

Favorite Categories
Autos

* Car Insurance
* Used Cars
* Auto Repair

Education

* Online Education
* School Loan
* Home School

Business

* E-Commerce
* Home Business
* MBA

Employment

* Employment Services
* Work at Home
* Job Search

Financial Services

* Debt Consolidation
* Credit Cards
* Mortgage

Entertainment

* Television
* Music
* MP3

Health

* Medical Insurance
* Weight Loss
* Diet

Home

* Home Security
* Refinancing
* Real Estate

Lifestyle

* Personals
* Fitness
* Pets

Shopping

* Electronics
* Flowers
* Gifts

Technology

* Web Hosting
* Computers
* Laptops

Travel

* Car Rental
* Airlines
* Hotels

Search the Web:


CTRL-D to Bookmark This Page | Drag This Link To Your Home Button
© 2006 MDNH, Inc.


also, blah-blah.com doesn't resolve to 4.18.83.3, it resolves to 66.116.125.121 so I'd verify your dns settings... :)
 

pcgh

Active Member
Jun 25, 2003
43
0
156
I FIXED MINE! :)

I tried everything I could think of and then on a whim I removed everything out of my exim.conf that had been manually added in the past - specifically the ACL section. With that removed, there were no more false "relay" messages!

So, I went back and recreated the ACL section from scratch (using http://www.webhostgear.com/175.html as a starting point). After that, things were back to normal.

I haven't touched exim.conf in a very, very long time so I figure a cPanel update might have messed things up. Anyway, hopefully this helps someone else.

Tony