The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim won't restart via cpanel, major exim problems

Discussion in 'E-mail Discussions' started by amaltemara, Jan 5, 2008.

  1. amaltemara

    amaltemara Member

    Joined:
    Dec 7, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I am having major exim problems.

    When I restart exim via whm 'restart services' function, I get a message saying:

    Attempting to restart exim
    Waiting for exim to restart.... . . . . . . . . . . finished.
    exim status
    root 2751 0.2 0.1 3760 1448 ? S 11:11 0:00 antirelayd
    exim has failed, please contact the sysadmin.

    I can restart exim via /etc/init.d/exim restart, but it will then fail less than 1 day later...

    /var/log/exim_mainlog doesn't show anything when whm is trying to restart exim...

    I have followed the whm/cpanel instructions found here: http://servertune.com/kbase/entry/34/

    <<<<
    For the cPanel/WHM v11.x
    Login to the WHM >> Main >> Service Configuration >> Exim Configuration Editor
    Scroll down the page and click on the button "Reset All Configs to Default" then SSH to the server and run these commands at the prompt:

    /scripts/buildeximconf
    /scripts/mailperm
    /scripts/eximup --force
    >>>>


    Here is the output of the last command: '/scripts/eximup --force'
    Notice, it's still failing, and it gives me an error of /etc/exim.crt not found...

    <<<<<<
    Fetching http://diff.cpanel.net/exim/4.68-1/centos/5/exim-4.68-1_cpanel_maildir.i386.rpm (0)....@209.85.80.214......connected......receiving...1%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done
    Preparing... ########################################### [100%]
    1:exim ########################################### [100%]
    2008-01-05 11:15:19 non-existent configuration file(s): /etc/exim.conf
    2008-01-05 11:15:19 non-existent configuration file(s): /etc/exim.conf
    Enabled system filter options: fail_spam_score_over_200|attachments|spam_rewrite
    Enabled ACL options in block ACL_RATELIMIT_BLOCK: 0tracksenders
    Enabled ACL options in block ACL_RBL_BLOCK:
    Enabled ACL options in block ACL_PRE_RECP_VERIFY_BLOCK: dictionary_attack
    Enabled ACL options in block ACL_TRUSTEDLIST_BLOCK: trustedmailhosts
    Enabled ACL options in block ACL_NOTQUIT_BLOCK: ratelimit
    Enabled ACL options in block ACL_CONNECT_BLOCK: ratelimit|spammerlist
    Enabled ACL options in block ACL_SPAM_BLOCK: deny_spam_score_over_200
    Detected spam handling in acls, disabling spamassassin in routers & transports!.
    SpamAssassin method remains unchanged
    Configured options list is:
    Provided options list is: hostlist senderverifybypass_hosts|hostlist skipsmtpcheck_hosts|hostlist spammeripblocks|hostlist backupmx_hosts|hostlist trustedmailhosts|domainlist user_domains|smtp_receive_timeout|ignore_bounce_errors_after|timeout_frozen_after|auto_thaw|callout_domain_negative_expire|callout_negative_expire|acl_smtp_connect|acl_smtp_notquit|spamd_address
    Exim Insert Regex is: lookuphost|virtual_userdelivery|virtual_aliases|virtual_user|address_pipe|localuser
    Exim Replace Regex is: virtual_sa_user|sa_localuser|virtual_sa_userdelivery|local_sa_delivery|central_filter|central_user_filter|democheck|fail_remote_domains|has_alias_but_no_mailbox_discarded_to_prevent_loop|literal|local_delivery|local_delivery_spam|localuser|localuser_spam|lookuphost|remote_smtp|userforward|virtual_aliases|virtual_aliases_nostar|virtual_user|virtual_user_spam|virtual_userdelivery|virtual_userdelivery_spam
    Exim Match Insert Regex is: maildir_format|quota_directory
    Adding maildir specific local_delivery to exim config
    Adding maildir specific local_delivery_spam to exim config
    Adding maildir specific address_pipe to exim config
    Adding maildir specific virtual_userdelivery_spam to exim config
    Adding maildir specific virtual_userdelivery to exim config
    Exim version 4.68 #1 built 02-Sep-2007 09:21:16
    Copyright (c) University of Cambridge 2006
    Berkeley DB: Sleepycat Software: Berkeley DB 4.3.29: (January 7, 2007)
    Support for: crypteq iconv() PAM Perl OpenSSL Content_Scanning Old_Demime Experimental_DomainKeys
    Lookups: lsearch wildlsearch nwildlsearch iplsearch dbm dbmnz
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile/maildir autoreply pipe smtp
    Size of off_t: 8
    Configuration file passes test! New configuration file was installed.
    Exim Perl Load List is: boxtrapper|checkpass_cphulkd|checkspam|checkspam2|checkuserquota|fast_accountfunc|fast_checkvalias|fast_isdemo|safefile|spam_acl_support
    /etc/exim.pl.local installed!
    chown: cannot access `/etc/exim.crt': No such file or directory
    chown: cannot access `/etc/exim.key': No such file or directory
    Waiting for exim to restart..............finished.

    root 3570 0.2 0.1 3764 1452 ? S 11:15 0:00 antirelayd

    exim has failed, please contact the sysadmin.
    Installing latest version of antirelayd ... Done
    /scripts/mailscannerupdate: This script should not be run manually. If you really wanted to do that, please add --force
    exim: no process killed
    exim: no process killed
    Waiting for exim to restart..............finished.

    root 3658 0.0 0.1 3760 1444 ? S 11:15 0:00 antirelayd

    exim has failed, please contact the sysadmin.
    Install Complete
    >>>>>>>


    I then when to WHM in 'manage service ssl certificates', and regenerated my certificate for exim, and executed the '/scripts/eximup --force' again, but still get the same results

    Anybody have an idea where I need to look next????

    I have successfully recieved mail, but only after adding my domain to /etc/localdomains and starting the service manually with /etc/init.d/exim start. But this is not the preferred method...

    Thanks in advance!


    but still the same thing
     
  2. beeheyv

    beeheyv Registered

    Joined:
    Jan 18, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
  3. erick_paper

    erick_paper Well-Known Member

    Joined:
    Apr 19, 2005
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    16
    I had the same problems. Reset all EXIM configurations, ACL etc. Then upcp-ed and did all the Exim reinstalls suggested on this thread and several others like it.

    My exim is working for now, but I see these errors

    Code:
    LOG: MAIN
      failed to open DB file /var/spool/exim/db/wait-remote_smtp: Permission denied (euid=47 egid=12)
      SMTP>> QUIT
    
    Why is this permission being denied?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Make sure that all the files within the /var/spool/exim/ tree are owned by mailnull:mail. If there's still a problem, then you can stop exim and delete all the files in /var/spool/exim/db/ (don't delete the directory) and then restart exim. Exim will recreate the files within the /db directory as it needs them.
     
Loading...

Share This Page