The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim won't send

Discussion in 'General Discussion' started by cyanide, Mar 29, 2005.

  1. cyanide

    cyanide Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Toronto, Canada
    I'm having an issue with the exim server sending emails.
    I can receive email no problem.
    Running Fedora Core1 R161

    I think I have tried just about every possible fix I can find, such as
    - upgrading / downgrading cpanel and exim
    - revert to default exim config

    the error I'm getting when trying to force a send mail through whm is
    Code:
    Message 1DGKUl-0004z3-Nx is not frozen
    delivering 1DGKUl-0004z3-Nx
    Connecting to somedomain.com [xx.xx.xxx.xx]:25 ... failed
    LOG: MAIN
      somedomain.com [xx.xx.xxx.xx]: Connection refused
    LOG: MAIN
      == user@somedomain.com R=lookuphost T=remote_smtp defer (111): Connection refused
    This is a server-wide problem affecting all domains...

    Can someone throw some ideas my way ?>

    Thanks... incidentally, I came across this dns problem in WHM - not sure if it's related though
     
  2. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    check for firewall blocking port 25.
     
  3. cyanide

    cyanide Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Toronto, Canada
    thanks for your response. unfortunately, i don't have access to the firewall.
    the DC controls it... but I did ask if they can see if it's a firewall / router problem, they said no

    hmm... i dunno
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    do u have the server root ?

    if yes {
    do at shell as root
    #iptables -F
    }
    else {
    ask the server admin or anyone who has the root to do the same.
    }

    It must be the firewall running inside the server.
     
  5. cyanide

    cyanide Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Toronto, Canada
    thanks linux-image, I really appreciate your responses

    As it turns out, I turned off the smtp tweak and presto! - email is flowing again. :)

    strange because i have the tweak on in other machines and no problems. :confused:
     
  6. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    i was not wrong though :) turning on smtptweak will add some rules to your iptables. you can check it by checking the iptables by enabling and disabling it.

    but it is strange that it works for one and doesnt for another.
     
Loading...

Share This Page