The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

exim

Discussion in 'General Discussion' started by petter.pan, Dec 29, 2004.

  1. petter.pan

    petter.pan Member

    Joined:
    Dec 29, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi
    when i use php scripts to send mail,it failed;
    less /var/log/exim_mainlog
    2004-12-29 20:57:52 1CjpZY-0004S0-4p <= nobody@usa1x.idc4u.net U=nobody P=local S=334
    2004-12-29 20:57:52 1CjpZY-0004S0-4p failed to expand condition "${perl{checkspam}}" for lookuphost router: you are not permitted to
    relay mail at /etc/exim.pl line 511.

    2004-12-29 20:57:52 1CjpZY-0004S0-4p failed to expand condition "${perl{checkspam}}" for literal router: you are not permitted to re
    lay mail at /etc/exim.pl line 511.

    how can i fix the problem?
    Best regards
     
  2. bashprompt18

    bashprompt18 Active Member

    Joined:
    Jun 27, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Garden Valley, Ca
    This is not a problem with exim, it's just not configured to allow your ip addres to
    relay. The Cpanel install of exim is quite secure when it comes to open relay so
    if you allow the relay it will not be a problem, or you can call sendmail from the
    command line in your scripts and that's linked to exim but should be less of a problem.

    -John
     
  3. petter.pan

    petter.pan Member

    Joined:
    Dec 29, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    hi
    thank u
    i check my php.ini
    sendmail_path = /usr/sbin/sendmail -t -i
    my question is how to send mail as nobody,because apache is runind as" nobody",
    Best regards
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The reason is that you don't have phpsuexec enabled (therefore the script is running as nobody user) and you have the following enabled:

    WHM > Tweak Settings > Prevent the user 'nobody' from sending out mail to remote addresses

    There's no way around that. You either need phpsuexec enabled on the server or uncheck that option.
     
  5. petter.pan

    petter.pan Member

    Joined:
    Dec 29, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    hi
    thank u very much
    :)
     
Loading...

Share This Page