The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim

Discussion in 'General Discussion' started by derivativ, Apr 18, 2005.

  1. derivativ

    derivativ Member

    Joined:
    Mar 10, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Howto
    route nobody's mail to /dev/null


    ??????????????/
     
  2. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    If this is referring to outgoing mail, I assume you are trying to find a way of preventing the user 'nobody' from sending out mail?

    In WHM > Tweak Settings, check the option "Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)"

    Bear in mind what is says: "php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively".

    This will only work nicely if you have phpsuexec and suexec enabled, otherwise all php and cgi scripts would have problems sending mail.
     
  3. derivativ

    derivativ Member

    Joined:
    Mar 10, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    :)

    ok i know that

    but i would like all incoming mail to nobody going to /dev/null
     
  4. protocol

    protocol Well-Known Member
    PartnerNOC

    Joined:
    Apr 13, 2004
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    I wanted to do this too. I haveonly come up with forwarding it to another domain, prefereably on the same server that itself forwards to :blackhole:
     
  5. Renjith Rajan

    Renjith Rajan Member

    Joined:
    Aug 22, 2004
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    One method that i am aware is

    put the following line in /etc/aliases or /etc/localaliases

    nobody: :blackhole:
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You should use :fail: never :blackhole: ;)
     
  7. Renjith Rajan

    Renjith Rajan Member

    Joined:
    Aug 22, 2004
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    This will leave all the mails generated by the server to nobody in the queue...Usually no mails are received from outside to nobody@servername..am i right?
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you're referring to my question, then no:
    http://www.configserver.com/free/fail.html

    Since emails to nobody woul be rejected anyway, I cannot see much point in making any changes. If you are receiving emails from the nobody user, set it to nothing in WHM > Change System Mail Preferences > Nobody's email.
     
Loading...

Share This Page