The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim4 - Syntactically invalid argument question

Discussion in 'General Discussion' started by PeteC, Jul 11, 2003.

  1. PeteC

    PeteC Well-Known Member

    Joined:
    May 8, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    Fortunately, I haven't had too many problems with the Exim4 upgrade. But one perplexes me, and I thought I'd run it by anybody here willing to help.

    I'm getting a lot of this error message in the exim_rejectlog:

    syntactically invalid argument(s): correo_internet.colpatria.com

    I already ran into the underscore issue and I have added the line:

    helo_allow_chars = _

    This got rid of these messages for all hosts except this particular one.

    Does anybody know what's syntactically invalid about this host name?

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  2. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    I have already posted the fix for this. It is because you are receiving an email from a machine that has an _ in the name of it. Exim4 does not allow these to pass for some reason. Here is the work around:

    vi /etc/exim.conf

    Go to the MAIN CONFIGURATION section and add this line:

    helo_allow_chars = _

    Now restart exim /etc/init.d/exim restart

    For safeguarding make exim.conf unwritable chattr -i /etc/exim.conf

    This allows these servers to pass now. If you don't make exim.conf unwritable it will overwrite your change each time exim updates.

    cPanel.net Support Ticket Number:
     
  3. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Pete, is that the address giving problems or did you change it?

    correo_internet.colpatria.com

    Notice there is no @

    cPanel.net Support Ticket Number:
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Build 170 is a lot more lenient with invalid syntaxs. You should upgrade to if if you are having problems

    /scripts/updatenow
    /scripts/exim4

    cPanel.net Support Ticket Number:
     
  5. tAzMaNiAc

    tAzMaNiAc Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    I'd just make a copy like exim.conf.good_date. If you chattr +i exim.conf it won't get the thing installed unless yuo chattr -i it! Or did I miss something at the latest release? :-D

    cPanel.net Support Ticket Number:
     
  6. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Edit: not having run '/scripts/exim4' before, wasn't aware it uses it's own version numbers, which is where the 170 comes in -- in case anyone else was wondering. ;)


    'nother Edit: seems that using '/scripts/exim4' leads to a bit of a loop:

    2003-07-11 08:27:38 socket bind() to port 25 for address (any IPv4) failed: Address already in use: waiting before trying again
    2003-07-11 08:27:38 socket bind() to port 465 for address (any IPv4) failed: Address already in use: waiting before trying again

    Stopping Exim for a few seconds then restarting seems to fix it.
     
    #6 Website Rob, Jul 11, 2003
    Last edited: Jul 11, 2003
  7. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We were getting those port errors to Rob. We updated yesterday morning and it seems to have gone away. Before the release yesterday morning we would have to stop and start Exim about every 2 hours to keep it running. Cpanels wonderful response was EMAIL us your passwords and we will go in and monkey with it. They didn't actually say what causes the port problems.

    The reason I chattr the exim.conf was just for safeguard. We are using Mailmon to help reduce internal spam and it has a chattr on /usr/sbin/sendmail for the script to not get overwritten. Since we only do manual updates we just make a most current backup then unlock for the update.

    cPanel.net Support Ticket Number:
     
  8. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    Just tried doing the updatenow and the exim4 scripts to get to the latest version. It still rejects servers with the underscore in their name. You will still have to add the helo_allow_chars = _ line.

    cPanel.net Support Ticket Number:
     
  9. PeteC

    PeteC Well-Known Member

    Joined:
    May 8, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    Kris, I've had the helo_allow_chars = _ in there for several days already.

    Is it possible there's a certain place it needs to go and I don't have it in the right place? I have it in the Main configuration section, just under:

    # primary hostname =
    deliver_queue_load_max = 3
    auto_thaw = 1h

    helo_allow_chars = _

    Much thanks to all the helpful folks who have posted in this thread. Hopefully I'll get to the bottom of this soon.

    cPanel.net Support Ticket Number:
     
  10. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Try adding helo_accept_junk_hosts = *

    cPanel.net Support Ticket Number:
     
  11. PeteC

    PeteC Well-Known Member

    Joined:
    May 8, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    You know, what seems to be happening is that when I restart Exim from WHM, it's not picking up the new /etc/exim.conf. Because I've added some SPAM protection I use, and that's not enabled either.

    So probably I'm OK with the helo_allow_chars = _ line, but why wouldn't restarting the Exim service pick up my changed /etc/exim.conf line? This works fine on another server of mine...

    cPanel.net Support Ticket Number:
     
  12. PeteC

    PeteC Well-Known Member

    Joined:
    May 8, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Texas
    Just so nobody wastes any more time on this. The problem was that Exim was refusing to shut down during a restart. I eventually did get it to restart, and now I'm fine. I tried a lot of things to accomplish the restart; it seems restarting BIND was what worked. Not sure why that is so, but spend your time on someone else's problem now, as mine is fixed.

    Another round of thanks to all you helpful folks.

    cPanel.net Support Ticket Number:
     
  13. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Sorry guys, its build 180 that has this change in it.

    cPanel.net Support Ticket Number:
     
  14. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    I think you hit the nail on the head, Pete.

    My logs show eMail addresses with: _ * - in them, all get through and I have not made any changes to the default "exim.conf" file -- other than adding the RBLs. Mind you, I don't run Spam Assassin either as I have found it causes more trouble (for me) than it is worth.

    As for shutting down, restarting services, not sure if your problem was doing it from WHM, but I have noticed that when in 'root' and using:

    /etc/init.d/'required_service' restart ( i.e., in this case: /etc/init.d/exim restart )

    seems to work best.

    cPanel.net Support Ticket Number:
     

Share This Page