The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim4 woes...

Discussion in 'General Discussion' started by qwerty, Jul 23, 2003.

  1. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    we updated to Cpanel7 stable + Exim4 recently (from 6.4 stable) ..

    One client is unable to send email all of a sudden without having modified any of their settings .. the error logged in exim_mainlog is

    2003-07-23 21:59:37 19fIHR-0006cg-09 H=(domain.ws) [203.194.1.1] F=<username@domain.ws> rejected after DATA: syntax error in 'From:' header when scanning for sender: malformed address: <username@domain.ws> may not follow username@domain.ws in "username@domain.ws <username@domain.ws>"

    Any ideas?

    cPanel.net Support Ticket Number:
     
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    From the error message it looks like your client has their email client setup to send mail with username@domain.ws as their name. Have them change the name field to an actual name and attempt to send mail.

    cPanel.net Support Ticket Number:
     
  3. jamesbond

    jamesbond Well-Known Member

    Joined:
    Oct 9, 2002
    Messages:
    738
    Likes Received:
    1
    Trophy Points:
    18
    Why would this not be allowed though?

    cPanel.net Support Ticket Number:
     
  4. pagedeveloping

    pagedeveloping Well-Known Member

    Joined:
    Jun 11, 2003
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New York
    syntax error in 'From:' header

    sais it all!!!

    Have your client delete the whole From line and just enter their email address. this should take care of their problem.

    cPanel.net Support Ticket Number:
     
  5. qwerty

    qwerty Well-Known Member

    Joined:
    Jan 21, 2003
    Messages:
    213
    Likes Received:
    0
    Trophy Points:
    16
    the 'real name' was set as user@domain.ws in the email app which appears to confuse exim4, on top of that the email app that was being used doesn't automatically add quotes (like outlook and others).

    Anyway, if anyone gets this sort of problem now you know why. To fix it either just put a normal name eg. John in the name field (as suggested by ciphervendor), or if you put an email address, then put quotes around it.

    cPanel.net Support Ticket Number:
     
  6. elleryjh

    elleryjh Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    479
    Likes Received:
    0
    Trophy Points:
    16
    Exim rejects incoming email with this format too. Is there a reason? A customer is complaining because he is not getting list emails! Is there a way to disable checking for this?
     
  7. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    Did you find the solution? I'm getting this errors too.

    Thank you.
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The solution is mentioned in the thread, make sure that the client is not using an email address as their account name description in their email client.
     
  9. cyanide

    cyanide Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Toronto, Canada
    Yes, I'm having the exact same email problem.
    The sender is sending from a Mac - X-Mailer: Apple Mail (2.553)

    Could this be a bug in apple mail ? ..been searching google for a while with no results
     

Share This Page