Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

exim_mainlog being written to and Exim is not running

Discussion in 'E-mail Discussion' started by jmark, Mar 29, 2011.

  1. jmark

    jmark Member

    Joined:
    Aug 6, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    51
    My server uses Postfix as MTA. I have disabled Exim, Mailman, and IMAP using WHM and yet exim_mainlog is still being written to and also very frequently. How can I stop it from being written to? These are the type of entries that are being logged.
    Thanks


    2011-03-29 21:57:35 1Q4kf9-0001Mw-H3 Completed
    2011-03-29 22:24:30 1Q4l5B-0002dS-Ih <= root@example.com U=root P=local S=737
    2011-03-29 22:24:30 1Q4l5B-0002dS-Ih User 0 set for local_delivery transport is on the never_users list
    2011-03-29 22:24:30 1Q4l5B-0002dS-Ih == root@example.com R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    2011-03-29 22:24:30 1Q4l5B-0002dS-Ih ** root@example.com <root@example.com>: retry timeout exceeded
    2011-03-29 22:24:31 1Q4l5C-0002da-BR <= <> R=1Q4l5B-0002dS-Ih U=mailnull P=local S=1658
    2011-03-29 22:24:31 1Q4l5C-0002da-BR User 0 set for local_delivery transport is on the never_users list
    2011-03-29 22:24:31 1Q4l5C-0002da-BR == root@example.com R=localuser T=local_delivery defer (-29): User 0 set for local_delivery transport is on the never_users list
    2011-03-29 22:24:31 1Q4l5C-0002da-BR ** root@example.com <root@example.com>: retry timeout exceeded
    2011-03-29 22:24:31 1Q4l5C-0002da-BR root@example.com <root@example.com>: error ignored
    2011-03-29 22:24:31 1Q4l5B-0002dS-Ih Completed
    2011-03-29 22:24:31 1Q4l5C-0002da-BR Completed
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is the exim service still running as well?

    Code:
    ps aux | grep exim
    If it is running, shut if off:

    Code:
    /etc/init.d/exim stop
    Then ensure it isn't listed in chkconfig for run levels to start on boot:

    Code:
    # chkconfig --list exim
    exim           	0:off	1:off	2:on	3:on	4:on	5:on	6:off
    If it has on for any of these, run:

    Code:
    chkconfig --del exim
    Also, check the exim rpms aren't there anymore:

    Code:
    # rpm -qa | grep -i exim
    exim-4.69-29_cpanel_maildir
    Remove the rpm if it is still existing:

    Code:
    rpm -e exim-4.69-29_cpanel_maildir
    You might also want to move the exim files:

    Code:
    mv /etc/exim* /root/
    mv /usr/sbin/exim /usr/sbin/exim.bak
    Finally, ensure in WHM > Update Preferences that exim is set to "Never" for cPanel Package Updates.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jmark

    jmark Member

    Joined:
    Aug 6, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    51
    Thanks for the info.
    It worked out well
     
  4. jmark

    jmark Member

    Joined:
    Aug 6, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    51
    I am now seeing this is my lfd.log file

    lfd[12084]: *Email Queue* Unable to obtain exim queue length within 30 seconds - Timed out

    It looks like there is a process trying to use exim. Is there some known processes in which uses exim? Is so which are these and how do I stop them? I am thinking most likely it is some service configurable from WHM.

    Thanks
    John
     
  5. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The service that is still trying to query the queue is CSF and LFD from that notification. This isn't a cPanel notification nor service. You'll have to stop LFD from trying to do that check, which would need to be directed to their forum:

    ConfigServer Scripts Forum &bull; Index page
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. jmark

    jmark Member

    Joined:
    Aug 6, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    51
    Thanks, I have fixed the issue in csf.conf
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice