The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Exim's mailips option not working

Discussion in 'E-mail Discussions' started by NetShapersInc, Jul 24, 2012.

  1. NetShapersInc

    NetShapersInc Member

    Joined:
    Apr 13, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi guys,

    Quick question:

    We are trying to send mail out on a different IP through our WHM. Our main IP is on a blacklist, and we can't seem to get it off. We've corrected the problem (client's email account was comprised), and we're still experiencing problems weeks later.

    I've edited the mailips file to say:

    *: 1.1.1.1 (the IP we want to send mail through though, obviously)

    I've enabled the option in the Configuration Manager to use mailips to send mail. However, it is not working.

    Any ideas on why it wouldn't be working?

    WHM 11.32.3 (build 21) VPS Optimized3
    CENTOS 6.3 i686
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is it trying to send still through the old IP or it simply isn't sending?

    If it isn't sending, the firewall might be the issue if the server has rules in place to only allow port 25 outgoing on the prior IP.
     
  3. NetShapersInc

    NetShapersInc Member

    Joined:
    Apr 13, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Its still sending through the main IP of the box. I wish it was as simple as a firewall issue, but its not looking like it.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Could you submit a ticket for us to investigate further? If it is still sending using the main IP rather than the gateway IP designated in /etc/mailips file, then something is definitely wrong. You can submit a ticket using WHM > Support Center > Contact cPanel or using the link in my signature.
     
  5. NetShapersInc

    NetShapersInc Member

    Joined:
    Apr 13, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Sure, ticket submitted through our datacenter: Ticket ID#: 2959482
     
  6. NetShapersInc

    NetShapersInc Member

    Joined:
    Apr 13, 2012
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    For anyone finding this later: the problem ended up being with our iptables config. It was forcing everything out on our main IP.
     
Loading...

Share This Page