eximstats failed after update

bofla

Member
Sep 1, 2002
20
0
151
I'm stumped on this one:
Starting eximstats: Can't locate auto/Cpanel/cPanelFunctions/getmydbhost.al in @INC (@INC contains: /usr/lib/perl5/5.8.4/i686-linux /usr/lib/perl5/5.8.4 /usr/lib/perl5/site_perl/5.8.4/i686-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl . /usr/local/cpanel /usr/local/cpanel /scripts /usr/local/cpanel /scripts) at /usr/local/cpanel/bin/starteximstats line 25

upcp ran ok, fixed the new stunnel issue but this seems out of control. Any idea how to reinstall cPanelFunctions ?

Thankies.
 

orion7144

Registered
Jun 29, 2005
1
0
151
I have the same issue. Also when I try to login to cpanel it comes up with a blank page. WHM works fine but says bind failed (its working thought)
 

ujr

Well-Known Member
Mar 19, 2004
290
0
166
Try to force updating first:

/scripts/upcp --force

If that still doesn't work try:

/scripts/realperlinstaller --force DBD::mysql

then

/etc/init.d/cpanel restart
 

Spiral

BANNED
Jun 24, 2005
2,020
8
193
Starting eximstats: Can't locate auto/Cpanel/cPanelFunctions/getmydbhost.al in @INC (@INC contains: /usr/lib/perl5/5.8.4/i686-linux /usr/lib/perl5/5.8.4 /usr/lib/perl5/site_perl/5.8.4/i686-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl . /usr/local/cpanel /usr/local/cpanel /scripts /usr/local/cpanel /scripts) at /usr/local/cpanel/bin/starteximstats line 25
Several of our servers just started doing the same thing and is generating the exact same
error message following a regular cpanel update.