eximstats failed @ Wed May 24 09:37:45 2006. A restart was attempted automagicly.

ilan

Member
Jan 8, 2005
17
0
151
I have just updated the apache and php module. I get an email from my server every minute with this inside:

eximstats failed @ Wed May 24 09:37:45 2006. A restart was attempted automagicly.

How do I stop that? :eek:

Thanks,
Ilan
 

mattbaros

Registered
Jun 2, 2005
4
0
151
I have the same problem...

I ran the script

/scripts/restartsrv_eximstats
as suggested by Chirpy and got the following error:

DBI connect('eximstats:localhost','eximstats',...) failed: Client does not support authentication protocol requested by server; consider upgrading MySQL client at /usr/local/cpanel/bin/eximstats line 264
Can't Connect at /usr/local/cpanel/bin/eximstats line 267.
I looked at the file the error referred to and it references an eximstats password.

When I did the upgrade to mySql 4.1 in WHM I also selected the "Use old style (4.0) passwords with mySQL 4.1" checkbox

Any suggestions on how to get this eximstats to be able to connect to the 4.1 database?

Thanks,
mb
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,462
25
473
Go on, have a guess
The following usually fixes that for me:

/scripts/perlinstaller --force Bundle::DBD::mysql

Then try restarting eximstats. If it doesn't help, edit /etc/my.cnd and check that it does have

old_passwords

under the [mysqld] section and restart mysql if you add it.
 

mattbaros

Registered
Jun 2, 2005
4
0
151
Thank you so much...

This command did seem to fix it (at least I am not getting the error email anymore).

I also checked the /etc/my.cnf and found that it did not say "old_passwords" even though I did check mark this in WHM. I went ahead and added it and restarted, even though I wasn't getting the error anymore about eximstats.

Thanks again for the help.
mb