The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

eximstats failed

Discussion in 'General Discussion' started by spike326, Mar 12, 2004.

  1. spike326

    spike326 Member

    Joined:
    Jan 18, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I keep getting eximstats failed emails, how do I go about resolving this issue?
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
  3. jadmire

    jadmire Registered

    Joined:
    Mar 13, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I've also been getting "eximstats failed" messages every eight minutes or so since about 7 pm last evening. This is very puzzling since everything else on the server seems to be working fine, including mail services. I tried the fixes described for editing my.cnf and repairing the eximstats database in WHM, but nothing seems to have worked so far. I am wondering whether I might not do better just to turn eximstats off if I can, because from what I read, all eximstats really does is to collect statistics on incoming and outgoing email. Since I'm the only person using my server, I wonder whether eximstats is really critical to the proper operation of the server.

    -Joe-
     
  4. spike326

    spike326 Member

    Joined:
    Jan 18, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I believe I was able to fix it, as I dont receive any failed messages. In WHM I just updated cpanel, then when to "Restart Services" and selected Mail Server (EXIM), then did a graceful reboot. Let me know if it works for you.
     
  5. jadmire

    jadmire Registered

    Joined:
    Mar 13, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    The only problem with that is, I think I'm already at the most recent version. See, the kernel went bad on my server at the beginning of this week, and my host had to do a reinstall on Tuesday. They put in the current build of Apache and, I think, the current build of WHM/CPanel at that time; the build is 9.1.0-RELEASE 72. Could be that a graceful reboot of the server might be what's needed, though.

    -Joe-
     
  6. magin

    magin Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    45
    Likes Received:
    1
    Trophy Points:
    6
    The sme problem here, eximstat failed, anybody have a solution?

    WHM 9.1.0 cPanel 9.1.0-S93
    RedHat 7.3 - WHM X v2.1.2
     
  7. inkandpixel

    inkandpixel Registered

    Joined:
    Jul 11, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    WHM 9.1.0 cPanel 9.1.0-R72
    RedHat 7.3 - WHM X v2.1.2

    I am having eximstats/mysql/ftpd failingevery 5 minutes also. Any solutions?
     
  8. beebware

    beebware Active Member

    Joined:
    Aug 2, 2003
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    We're getting the same problem on WHM 9.1.0 cPanel 9.1.0-S93 RedHat 7.3 - WHM X v2.1.2: only started having the problems since the automatic upcp update which update MySQL for some strange, unknown, reason (i.e. it was previously up to date):
    Tried restarting MySQL and EXIM and still the mails come :(
     
  9. inkandpixel

    inkandpixel Registered

    Joined:
    Jul 11, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Here's what I did.

    1 . Set my CPanel Update preferences to:
    Manual Updates Only (RELEASE tree)

    2. Ran CPanel Update
    Upgrade to Latest Version

    3. Restart Exim

    4. Graceful Server Reboot

    I haven't received anymore eximstats failed notices yet. (cross my fingers)
     
  10. Dillard

    Dillard Well-Known Member

    Joined:
    Feb 26, 2003
    Messages:
    114
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    The Netherlands
    Had the same problem here. Driving me nuts with eighty thousand messages in two days.

    Finally had some time to dive in: it seemed that somehow the eximstats database wasn't created and neither was the eximstats user.

    I took the eximstats password from /var/cpane/eximstatspass and created a mysql user with this password.

    Created a database eximstats and copied the structure from one of my other servers (I will include them below) and adjusted the specific database rights for the user eximstats on the database eximstats.

    Then fired up /usr/local/cpanel/bin/eximstats and it worked !

    Code:
    # phpMyAdmin SQL Dump
    # version 2.5.6-rc1
    # [url]http://www.phpmyadmin.net[/url]
    #
    # Host: localhost
    # Generation Time: Apr 06, 2004 at 11:24 PM
    # Server version: 4.0.17
    # PHP Version: 4.2.3
    # 
    # Database : `eximstats`
    # 
    DROP DATABASE `eximstats`;
    CREATE DATABASE `eximstats`;
    USE eximstats;
    
    # --------------------------------------------------------
    
    #
    # Table structure for table `sends`
    #
    
    CREATE TABLE `sends` (
      `mailtime` datetime NOT NULL default '0000-00-00 00:00:00',
      `msgid` char(15) NOT NULL default '',
      `email` char(100) NOT NULL default '',
      `processed` int(11) default NULL,
      `user` char(30) default NULL,
      `size` int(11) default NULL,
      `ip` char(20) default NULL,
      `auth` char(20) default NULL,
      PRIMARY KEY  (`mailtime`,`msgid`,`email`),
      KEY `user_msgid_index` (`user`,`msgid`),
      KEY `msgid_index` (`msgid`)
    ) TYPE=MyISAM;
    
    # --------------------------------------------------------
    
    #
    # Table structure for table `smtp`
    #
    
    CREATE TABLE `smtp` (
      `mailtime` datetime NOT NULL default '0000-00-00 00:00:00',
      `msgid` char(15) NOT NULL default '',
      `email` char(100) NOT NULL default '',
      `processed` int(11) default NULL,
      PRIMARY KEY  (`mailtime`,`msgid`,`email`),
      KEY `msgid_index` (`msgid`),
      KEY `processed_index` (`processed`)
    ) TYPE=MyISAM;
    
    
     
  11. Nathan D.

    Nathan D. Well-Known Member

    Joined:
    Mar 21, 2004
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Virginia
    How long should it take to update? My WHM/cPanel seems to be slow sometimes.
     
  12. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We don't actually get any warnings about eximstats being down, just shows perma failed in WHM for one server.
     
  13. Blackknight

    Blackknight Member

    Joined:
    Jul 12, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem. The databse is there, the mysql user is ok, eximstats is running, but WHm still shows it as being failed. It's really annoying since the customer is complaining about getting all of the eximstats failed messages.
     
  14. tambo

    tambo Member

    Joined:
    Apr 29, 2002
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    All I did was resetting Local MySQL Root Password. Now eximstats works perfectly ok.
     
  15. DWHS.net

    DWHS.net Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,569
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Tried all the fix (thanks by the way) but still it's broken. Off to cpanel support request :(
     
  16. faqall

    faqall Active Member

    Joined:
    Jul 17, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    wait, how do you make databases as root so i can try that as after updating my kernal and doing a forceful reboot i notice that the eximstats failed.
     
  17. grgur

    grgur Member

    Joined:
    Sep 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Split, Croatia
    type:
    service chkservd restart
     
  18. flash7

    flash7 Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    same problem here,
    RHL ES 3 - WHM 9.7.2 cPanel 9.7.7-R15

    eximstats failed :mad:
     
  19. okyanusmedya

    okyanusmedya Registered

    Joined:
    Sep 6, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have this same problem.

    My server information :
    WHM 9.7.2 cPanel 9.7.7-R15
    RedHat Enterprise 3 i686 - WHM X v3.1.0

    This problem after cpanel upgrade:
    kernel 2.4.21 20.ELPkg name/pattern
    kernel-source 2.4.21 20.ELPkg name/pattern
    kernel-utils 2.4 8.37.6Pkg name/pattern
    perl 5.8.0 88.7 Pkg name/pattern
    redhat-release 3ES 7.3 Config modified


    now , eximstats failed.

    root@atlas [~]# /usr/local/cpanel/bin/eximstats
    Can't locate DBD/mysql.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /
    usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl
    /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 .) at /usr/local/cpanel/bin/eximstats line 258.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/eximstats line 258.
     
  20. flash7

    flash7 Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    You must upgrade perl to 5.8.4
    and eximstats work ;)
     
Loading...

Share This Page