The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

eximstats failed

Discussion in 'General Discussion' started by xml, Jun 6, 2004.

  1. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    Ever since i edited my origional my.cnf file to optimize my server ( RHE 3 ) i got eximstats failed ,tried to fix it using all solutions posted in cpannel,ev1 servers,WebHostingTalk Forums

    when i usr/local/cpanel/bin/eximstats

    i get this output :

    DBI connect('eximstats:localhost','eximstats',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /usr/local/cpanel/bin/eximstats line 258
    Can't Connect at /usr/local/cpanel/bin/eximstats line 261.

    here is my.cnf file current content :

    [client]
    port = 3306
    socket = /tmp/mysql.sock

    [mysqld]
    port = 3306
    socket = /tmp/mysql.sock
    skip-locking
    max_connections = 500
    key_buffer = 16M
    myisam_sort_buffer_size = 64M
    join_buffer_size = 1M
    read_buffer_size = 1M
    sort_buffer_size = 2M
    table_cache = 1024
    thread_cache_size = 64
    wait_timeout = 1800
    connect_timeout = 10
    max_allowed_packet = 16M
    max_connect_errors = 10
    query_cache_limit = 1M
    query_cache_size = 16M
    query_cache_type = 1
    skip-innodb

    [mysqld_safe]
    open_files_limit = 8192

    [mysqldump]
    quick
    max_allowed_packet = 16M

    [myisamchk]
    key_buffer = 64M
    sort_buffer = 64M
    read_buffer = 16M
    write_buffer = 16M


    did any one had similar problem to this?

    i really hate those daily tons of #$%^* emails telling me eximstats failed
     
    #1 xml, Jun 6, 2004
    Last edited: Jun 6, 2004
  2. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    If you take out the wait_timeout line, then eximstats will stop failing.
     
  3. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    thanks GotHosting for replying

    i removed line
    wait_timeout = 1800

    restarted mysql
    restarted apache

    waited 15 minutes ...eximstats still failed

    restarted exim ... waited .... the light still red

    i even reboot the server ... waited .... eximstats still failed

    any suggestion?:(
     
  4. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    How many times did it fail? It will fail at least one time when you restarted mysql.
     
  5. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    GotHosting

    eximstats still red light ... even after i restarted mysql .... it never become green even for one time after restarting mysql

    i hope i understand your question correctly
     
  6. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    First you must determine if it is actually failed or not.

    ps -ax|grep eximstats

    Should return something like:
    6080 ? S 0:02 /usr/bin/perl /usr/local/cpanel/bin/eximstats

    If that is there, then it is actually running. If not, then your problems lies elsewhere...
     
  7. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    i did
    ps -ax|grep eximstats

    and i got
    18704 pts/0 S 0:00 grep eximstats

    if this mean eximstats is running then why i get red light in whm Service Status and all thease warning emails?

    and when i do /usr/local/cpanel/bin/eximstats

    why i get this out put

    DBI connect('eximstats:localhost','eximstats',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /usr/local/cpanel/bin/eximstats line 258
    Can't Connect at /usr/local/cpanel/bin/eximstats line 261.

    am very comfused :(
     
    #7 xml, Jun 8, 2004
    Last edited: Jun 8, 2004
  8. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    Ah, I'm not.

    Your MySQL is not running in general. Eximstats is not running (the grep eximstats is not from it running.)

    Try this:

    cd /tmp
    ln -s /var/lib/mysql/mysql.sock
    service chkservd restart
    /usr/local/cpanel/bin/eximstats

    See if that gets it to start.
     
  9. xml

    xml Well-Known Member

    Joined:
    Jan 15, 2004
    Messages:
    76
    Likes Received:
    1
    Trophy Points:
    8
    ok here is what happen

    i sent email 2 days ago to cpannel suport about this problem and they asked me root password so they can fix the problem


    when i did what you suggest GotHosting about :

    cd /tmp
    ln -s /var/lib/mysql/mysql.sock
    service chkservd restart
    /usr/local/cpanel/bin/eximstats

    i went to whm service status and the light was green at the same time i got email from cppanel support saying:

    I have recompiled Perl and fixed a MySQL problem which seemed to of fixed the eximstats problem. Please see how this is working now.

    Thank you.
    --
    Kyle Pinkley
    kyle@cpanel.net
    Customer Support Representative
    cPanel, Inc.


    wich made me so mad cuz in this i case i will not know wich solution fixed my eximstats

    so i send email to Kyle Pinkley ( cppanel support ) to tell me some details about the fix and he reply :

    I recompiled Perl via the Perl installer at http://layer1.cpanel.net.

    I also noticed that MySQL wasn't starting correctly. I added a line below in the [mysqld] section in the /etc/my.cnf file:

    socket=/var/lib/mysql/mysql.sock


    any way the eximstats is fixed now and i want to say thank you very much GotHosting for you great help and thanks to cpannel support for thier help :)
     
  10. GOT

    GOT Get Proactive!

    Joined:
    Apr 8, 2003
    Messages:
    900
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Norfolk, VA
    cPanel Access Level:
    DataCenter Provider
    I can say without reservation that is was MY fix that fixed it.

    ;)

    Jon
     
  11. Frank3D

    Frank3D Member

    Joined:
    May 11, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Similar problem eximstats failed

    I ran into the similar problem with receiving an eMail stating eximstats failed.

    was getting it about every 8 minutes.

    read through your notes above and tried that one the first sever I support and then finally found this to work. (tested it on a second server that started getting these messages)

    first I restarted mysql
    then rebuilt perl using the "Install RPM Module" and selecting perl(rebuild)

    after that I did a graceful reboot.

    which led to a restart of bind and apache

    and all is good!

    It seems I started receiving this after an apache update.
     
Loading...

Share This Page