The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

eximstats failing due to mysql

Discussion in 'General Discussion' started by Devil Inside, Apr 2, 2005.

  1. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    running Current 10.1 build 4
    MySQL 4.1.10a-standard

    Eximstats keep failing on 2 of my servers.

    When I restart cpanel I receive this error:
    Starting eximstats: DBI connect('eximstats:localhost','eximstats',...) failed: Client does not support authentication protocol requested by server; consider upgrading MySQL client at /usr/local/cpanel/bin/eximstats line 262
    Can't Connect at /usr/local/cpanel/bin/eximstats line 265.

    I have checked the box to use mysql 4.0 password in teak settings.

    Anyone have any ideas?
    cPanel techs said to rebuild the database and instructed me on how to do so. However, when I try - the root pass is continually rejected.

    I've tried resetting the pass - but it hasn't helped.
     
  2. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    Anyone have even a guess?

    cPanel tech support hasn't responded to me in over 24 hours. Somehow they always do that to me. I'll submit a ticket - get a response in under 20 minutes. Email back in less than 5 minutes - and *POOF* they disappear for a day or two.

    Does cPanel have some policy for their techs that tickets must be acknowledged quickly or something? Because that first response is usually pretty vague and/or flat out unhelpful.
     
  3. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    login to the box

    Does

    # mysql eximstats

    Drop you into mysql ?

    If so

    > check table sends;

    > repair table sends;

    > check table smtp;

    > repair table smtp;

    > quit;

    # /etc/init.d/exim restart

    # /etc/init.d/chkservd restart

    Also check what version of mysql is running, maybe rpm -qa | grep -i mysql

    Restart mysql

    # /etc/init.d/mysql stop

    # /etc/init.d/mysql start
     
  4. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    Thanks much for the reply. I really appreciate it.

    Unforunately it didn't help. Though the tables did need repairing :)

    Still getting the connection error...

    still haven't heard back from cPanel regarding of my tickets - and another one as yet to be replied to at all :mad:
     
  5. [iG]

    [iG] Member

    Joined:
    Oct 16, 2002
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    This is an error where the perl module DBD-MySQL is not upto date.

    I am assuming you are using MySQL.

    You need to update to the latest DBD-MySQL which is what eximstats uses to connect to MySQL.

    Once you do that, it will work fine.
     
  6. [iG]

    [iG] Member

    Joined:
    Oct 16, 2002
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
  7. Realist

    Realist Member

    Joined:
    Dec 4, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem and so far no luck in fixing it?
     
  8. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    Add old-passwords to my.cnf in the [MySQL] section and restart MySQL or check the use old passwords in 4.1 box in Tweak Settings in WHM.
     
  9. [iG]

    [iG] Member

    Joined:
    Oct 16, 2002
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Nothing there?
     
  10. gemby

    gemby Well-Known Member
    PartnerNOC

    Joined:
    Feb 16, 2002
    Messages:
    182
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Pula, Croatia
    cPanel Access Level:
    DataCenter Provider
    Yep, i confirm that nothing above works, eximstats would not start, R161 + mysql 4.1.....
     
  11. Devil Inside

    Devil Inside Well-Known Member

    Joined:
    Apr 4, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    16
    R161 doesn't have the check box for using version 4.0 passwords in tweak settings. And I gather other mysql database connections will also fail due to this.

    You need build 162 or more recent for the check box to be available.

    Anyhow - I finally got a response from a cPanel tech.. now listen up cuz it might help all of you...

    Which is total crap since he never logged into the server *unless it was only as admin...*

    I get a nifty email whenever someone su - to root...

    That was almost 24 hours ago. Which again, I replied to ina timely manner (1 hour or so) stating whatever he did, didn't work.

    I guess I'll hear from him again in a day or so... still no reply to the second ticket regarding another server. My guess is someone deleted it thinking it was a duplicate ticket. Same subject/body - just different IP's.
     
  12. iceboxman

    iceboxman Registered

    Joined:
    Jan 21, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1

    Wow! this actually worked for me. I figured I'd give it a shot and was pleasantly surprised.
     
  13. sumith

    sumith Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    96
    Likes Received:
    2
    Trophy Points:
    8
  14. EMS

    EMS BANNED

    Joined:
    May 10, 2003
    Messages:
    250
    Likes Received:
    0
    Trophy Points:
    0
    Got this happening on one server right now and I've tried everything to no avail.

    Still getting Client does not support authentication protocol requested by server etc.

    I've tried everything in this thread and also /scripts/mysqlup --force but nothing seems to fix it. This is happening after a mysql upgrade to 4.1 today and the old passwords option is ticked in the settings.
     
  15. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Solution

    Hi

    Here is a solution if you ever get the error message below.

    It might be related to me upgrading mysql from 4.0 to 4.1.

    When restarting cpanel it gives.
    Starting eximstats: DBI connect('eximstats:localhost','eximstats',...) failed: Client does not support authentication protocol requested by server; consider upgrading MySQL client at /usr/local/cpanel/bin/eximstats line 264 Can't Connect at /usr/local/cpanel/bin/eximstats line 267.

    This is probably due to mysql being upgraded by still using the old version of the DBI and DBD::mysql perl modules.

    Code:
    $cpan
    cpan> get DBD::mysql
    (This should download the DBD module
    cpan> quit
    
    $ cd /home/.cpan/build or cd /root/.cpan/build
    $ cd DBD-mysql-3.0002
    $ perl Makefile.PL
    $ make && make install
    Now try restart cpanel ( /etc/init.d/cpanel restart )

    No more eximstats error :)
    Hope this can help someone :)

    Cheers
    Andy
     
  16. z3usy

    z3usy Member

    Joined:
    Apr 12, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    forlinuxsupport...

    Great fix! :)
     
  17. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    my pleasure :)

    Share the knowlege grasshopper . . . .
     
  18. jough

    jough Well-Known Member

    Joined:
    Aug 17, 2003
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Philadelphia, PA
    I had the same problem and the above fixed it. THANK YOU, forlinuxsupport.
     
  19. online_kn

    online_kn Member

    Joined:
    Jun 19, 2005
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    i have same problem with:

    Starting eximstats: DBI connect('eximstats:localhost','eximstats',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /usr/local/cpanel/bin/eximstats line 264
    Can't Connect at /usr/local/cpanel/bin/eximstats line 267

    soneone can help me how fix that
     
  20. forlinuxsupport

    forlinuxsupport Well-Known Member
    PartnerNOC

    Joined:
    Dec 22, 2004
    Messages:
    386
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Your mysql is putting the mysql.sock file in the wrong place or it doesnt exist

    root@ns4 [/]# ls -la /var/lib/mysql/mysql.sock
    srwxrwxrwx 1 mysql mysql 0 Feb 7 11:27 /var/lib/mysql/mysql.sock=

    Check you /var/lib/mysql diectory has correct permissions on otherwise mysql cant create its
    mysql.sock file


    root@ns4 [/]# ls -la /var/lib/mysql
    total 20672
    drwxr-x--x 7 mysql mysql 4096 Feb 7 11:27 ./
    drwxr-xr-x 8 root root 4096 Jan 17 15:40 ../
    drwxr-xr-x 2 mysql mysql 4096 May 23 2005 eximstats/
    drwxr-xr-x 2 mysql mysql 4096 Jan 30 12:30 horde/
    -rw-rw---- 1 mysql mysql 25088 May 23 2005 ib_arch_log_0000000000
    -rw-rw---- 1 mysql mysql 5242880 Feb 7 11:27 ib_logfile0
    -rw-rw---- 1 mysql mysql 10485760 Feb 7 11:27 ibdata1
    drwx--x--x 2 mysql mysql 4096 Jan 17 15:50 mysql/
    -rw-rw---- 1 mysql mysql 6 Jan 30 12:29 ns4.pid
    drwxr-xr-x 2 mysql mysql 4096 May 23 2005 test/

    Cheers
    andy
     
Loading...

Share This Page