The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

eximstats, i had to delete tables manually

Discussion in 'E-mail Discussions' started by droidman, Apr 6, 2012.

  1. droidman

    droidman Active Member

    Joined:
    Mar 9, 2009
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Hi, a friend of mine was running a mail server and had eximstats enabled, i dont know if it is at all possible to disable it but this server has a 120GB SSD hard drive that got almost full, eximstats was at 14GB and i tried to login to mysql and delete the tables but they got so huge that it was impossible, also it said they had to be fixed, so i went to the eximstats dir,
    cd /var/lib/mysql/eximstats
    checked for the biggest files
    ll -h
    and emptied them like this:
    > failures.MYD
    ...
    and so on, for the biggest ones.
    obviously this emptied them so i dont know if this damaged the structure. the server got fast again, i rebooted it and everything was ok untill now, today it started crashing, reboots are not working properly and tailwatch gets hangged when rebooting cpanel or the server.

    i belive that this is related to what i did, anyone knows a script to fix eximstats database structure and empty so i can create a cronjob or something? or disable eximstats.

    thanks
     
  2. droidman

    droidman Active Member

    Joined:
    Mar 9, 2009
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    nevermind, i belive i fix it.
    in a way, these databases are files, i went to another cpanel server with a similar configuration and downloaded the files wich are databases into the damaged one (i have also emptied them before)
    so they just had the structure of the database.
    i replaced them under /var/lib/mysql/eximstats on the damaged server, restarted mysql, tailwatchd, cpanel etc, the server seems to be working 100%.
     
Loading...

Share This Page