The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

External (Intermediary) MX Record Not Receving Local Mail

Discussion in 'E-mail Discussions' started by niatech, Jul 31, 2007.

  1. niatech

    niatech Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    Hello all,

    For the past year or so, a reseller client has been setting up domains with external MX records for spam processing, but the mail eventually comes back to our mail server. All is working fine, except for new domains.

    When they try to externalize the MX record, it removes the domain from /etc/localdomains? It never used to?

    Is anyone aware of a change in the new CPanel/WHM that may be causing this?

    Thanks!
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Have the customer log into their Cpanel account.
    - then select MX Entry
    - add the MX
    - CHECKMARK "Always accept mail locally even if the primary mx does not point to this server"

    Save the MX

    That should take care of it. If you don't checkmark that when modifying the MX for the domain, it will not accept mail for the domain locally.

    Mike
     
  3. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    Also,

    In WHM / Tweak Settings, under the MAIL section you'll see:

    Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed.

    Depending on if that is checkmarked or not, this would also affect what happens when the MX entry is changed. If this is checkmarked, then when somebody changes their domain MX within their Cpanel to something remote, it is going to yank the domain from /etc/localdomains and put it in /etc/remotedomains - thus causing the mail not to be delivered locally.

    But in reality, I think you really want to have this option checkmarked - as default behavior if somebody changes their MX to a remote server _should_ be that it doesn't handle mail for the domain locally - and if a customer of yours specifically needs the ability to do that, they would just checkmark the box in their Cpanel / MX Entry section that I described in the previous post.

    Mike
     
  4. niatech

    niatech Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    16
    Ahh! I see!

    Thanks guys!
     
Loading...

Share This Page