The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

External mail server problem.

Discussion in 'E-mail Discussions' started by benito, Aug 22, 2007.

  1. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    296
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Mar del Plata - Argentina
    Hello !

    I´m using in one domain an external mail server ( Google Apps ) and have this problem. Only when i send an email from another domain hosted in the same server, the email is routed directly to the same server where the domain is located insted going to the external mail server on google.

    I have to do something to tell my server that this domain is not taking emails locally ?
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    What you will want to do is this:

    REMOVE the domain from /etc/localdomains
    ADD the domain to /etc/remotedomains (if it isn't already in there)

    I'm not sure if you'll have to restart Exim or not.

    Mike
     
  3. benito

    benito Well-Known Member

    Joined:
    Jan 8, 2004
    Messages:
    296
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Mar del Plata - Argentina
    This works ! Those two files are used only for mail purposes, right ?
     
  4. jmauro8ac

    jmauro8ac Registered

    Joined:
    Jul 17, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    But if there is no local or remote folders

    Hi, I try it, I have google apps too and no mail () function working but my etc directory just have my domain folder <mydomain.com> there is not any localdomains or remotedomains. I try creating this folder and placing my domain folder on the remotedomains but it just not work. Any idea?
     
  5. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    etc/localdomains and etc/remotedomains are files, not folders. Also, your user folder should be in /home not in /etc Are you sure you're using a cpanel server?
     
  6. jmauro8ac

    jmauro8ac Registered

    Joined:
    Jul 17, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    No, I'm using a common cpanel account

    I have a reseller plan account that I admin with WHM. And I have ggogle apps on my common account at mydomain.com whit cpanel. So I guess that it is just on cpanel server. How can I get working google apps and mail () function. There is a "Relaying not permitted" error when I use the mail() function. Please help me. :confused:
     
  7. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Your best bet would be to contact your hosting provider.
     
  8. varunsolanki

    varunsolanki Registered

    Joined:
    Jan 8, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have the same problem. I'm using cpanel for the domain but as suggested above, my /etc folder is empty.

    I checked in the other folders as well, but i could not find any file in which i could modify/comment the localdomain.
    the folder structure in the site is as follows:
    /access-logs
    /etc
    /logs
    /mail
    /public_ftp
    /public_html
    /tmp
    /www

    kindly advice
     
  9. oshs

    oshs Well-Known Member
    PartnerNOC

    Joined:
    Sep 5, 2004
    Messages:
    146
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Run this on the server after changing the MX records for any domain:

    Code:
    # /scripts/checkalldomainsmxs
    You'll have to add the flag it specifies to force it.

    Regards,
    Suhail.
     
  10. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    It sounds like you are looking at /home/USERNAME/etc rather than /etc on the system. This can be the case if you are not the system administrator. If you do not have the password to username root, you will need to contact your hosting provider to help diagnose and resolve this issue.
     
Loading...

Share This Page