The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

external mail server will not resolve or setup

Discussion in 'E-mail Discussions' started by adtastichosting, Oct 24, 2009.

  1. adtastichosting

    adtastichosting Active Member

    Joined:
    Sep 13, 2008
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    I am running cpanel 11.24.5 and whm 11.24.2

    I have a domain we'll call domain.com. I want to point the mail for this domain to an external exchange mail server. I login to whm and go to edit dns zone and choose the domain and edit the record. here is how it looks for what I believe to be the pertinent fields:

    domain.com 14400 IN MX 0 mail.domain.com.
    mail 14400 IN CNAME domain.com.
    webmail 14400 IN A xxx.xx.xx.xx (where x's are external IP for the external mailserver)
    mail.domain.com 14400 IN A xxx.xx.xx.xx

    Now, "Always accept mail locally even if the primary mx does not point to this server." was always unchecked by default. However, whenever I would submit the record it still says "Reconfiguring Local Mail: This server will serve as the primary mail exchanger for domain.com's mail"

    SO, I went and in tweak settings unchecked "Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed." I tried it again. Now "Always accept mail locally even if the primary mx does not point to this server." is checked. So I uncheck it. I still get "Reconfiguring Local Mail: This server will serve as the primary mail exchanger for domain.com's mail".

    Of course invariably if I ping mail.domain.com I still get the ip for the server the domain is hosted on. Can anyone tell me what I am missing, doing wrong or need to change?
     
  2. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    This functionality has been broken for a couple of months. I think its because of some preparation for the new changes in 11.25.

    For some time now, whatever option you choose, it would automatically set the domain to local - you would have to remove the domain from /etc/localdomains and add it to /etc/remotedomains manually if you did not want local delivery.

    However, if you are on RELEASE - you should now be on 11.25 and your problem will be resolved.
     
  3. adtastichosting

    adtastichosting Active Member

    Joined:
    Sep 13, 2008
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6

    Thanks for the answer, nice to know now what the problem was after spending a week going round and round and finally losing the client. But better luck next time we'll know. I appreciate you finding the thread and answering it.
     
  4. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    I should add a couple of things...

    Fiirstly, the fact that cpanel sets the domain to "local" doesnt stop delivery to your external MX. All that does is accept mail for the domain if it is sent to the server. If you set the MX correctly, after DNS propagation, all mail will be sent to the external MTA - apart from mail sent from the cpanel server itself to the domain and mail sent directly to the cpanel server for the domain (i.e the MX has been ignored - often spam is sent this way).

    Secondly. Although we have experienced this issue on all of our cpanel servers it doesnt mean every cpanel customer has too - perhaps I was a bit hasty in saying that the functionality is broken, although that has been our experience.
     
Loading...

Share This Page