External SMTP Setup for one account

hmaddy

Well-Known Member
May 6, 2020
319
39
28
Chennai
cPanel Access Level
Root Administrator
one of my dedicated server hosted with 200+ accounts and one account have whmcs. in this whmcs account i need to configure external smtp(google workspace). But now its throwing error


SMTP Debug: SMTP Error: Could not authenticate.​


It was working fine on old server. this error happened on this new server. How to fix this.?? Already shooted one ticket to whmcs and got the following reply.

Please ensure that external SMTP connections are permitted in your new sever configuration: SMTP Restrictions | cPanel & WHM Documentation

But i not found any options like this. so please help and send me the step by step method.
 
Last edited by a moderator:

quietFinn

Well-Known Member
Feb 4, 2006
1,693
350
438
Finland
cPanel Access Level
Root Administrator
The setting is in WHM -> Server Configuration -> Tweak Settings -> Mail -> Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak).

Also if you use CSF it might be blocked there.
 

cPanelWilliam

Administrator
Staff member
Mar 13, 2018
119
20
93
Houston
cPanel Access Level
Root Administrator
Hey there! If your server uses CSF, you would also want to check to ensure that SMTP_BLOCK is disabled in the CSF configuration, as both that setting or SMTP Restrictions would prevent your WHMCS script from sending mail via Google Workspace.

As @quietFinn mentioned, you can also enable/disable SMTP Restrictions via WHM > Tweak Settings > "Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak)" (or through WHM > SMTP Restrictions).
 

quietFinn

Well-Known Member
Feb 4, 2006
1,693
350
438
Finland
cPanel Access Level
Root Administrator
If CSF is used I'd advise to set Restrict outgoing SMTP to root, exim, and mailman (FKA SMTP Tweak) => OFF, and in CSF SMTP_BLOCK => ON, and then add the WHMCS user to SMTP_ALLOWUSER.