Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Extreme CPU load, caused by Exim

Discussion in 'Workarounds and Optimization' started by AudunS, May 13, 2011.

  1. AudunS

    AudunS Member

    Nov 11, 2010
    Likes Received:
    Trophy Points:

    One of my cPanel-servers has problems with very high load. When I logged in a couple minutes ago the load was above 100. Top shows multiple exim-processes running by mailnull.

    What steps do I take from here to figure out the issue? Can I configure Exim to take care of something like this by itself? I'm guessing one of the users is sending out to much email, but I guess there would be settings to prevent this kind of problem.

    I have also tried different commands to delete everything in the exim-que, but unsuccessfully.

    Help needed! :)
  2. astopy

    astopy Well-Known Member

    Apr 3, 2003
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    It might not necessarily be caused by exim, but it might help if you set queue_only_load to a sensible value in the exim config (in the advanced editor).

    What do you get if you run vmstat in SSH?

Share This Page