The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Extremely painfully slow FTP

Discussion in 'General Discussion' started by LaxSlash1993, Oct 11, 2015.

Tags:
  1. LaxSlash1993

    LaxSlash1993 Member

    Joined:
    Oct 8, 2015
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Buffalo, NY
    cPanel Access Level:
    Root Administrator
    So, being honest here.... I love WHM and cPanel for functionallity. However, it's really taken a hit on my server's speed (I've been trying out different panels). Uploading/download files via FTP Passive mode (ProFTPd) starts and stops every 2 files. It will upload about 1 or 2 files quickly and then just stop in between these "upload bursts" as I call them for about anywhere from 1-10 seconds. Now I've used ProFTPd on this same exact server before without issue... so I know that it *shouldn't* be that the server specs are too weak. Connecting via FTP takes for ever too, sometimes upwards of 5-15 seconds.

    The specs are as follows:

    Code:
    XenVPS
    
    Total processors: 2
    Processor #1
    Vendor
    GenuineIntel
    Name
    Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
    Speed
    2000.042 MHz
    Cache
    15360 KB
    Processor #2
    Vendor
    GenuineIntel
    Name
    Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
    Speed
    2000.042 MHz
    Cache
    15360 KB
    [ 0.000000] Memory: 4045816k/4202496k available (6244k kernel code, 388k absent, 156292k reserved, 4178k data, 1604k init)
    
    total used free shared buff/cache available
    Mem: 4095224 731516 2897508 25220 466200 3297460
    Swap: 4194300 0 4194300
    Total: 8289524 731516 7091808
    
    
    One thing in particular that I noticed that's interesting is that buff/cache fills up VERY rapidly in the regular memory.


    Any ideas?
     
    #1 LaxSlash1993, Oct 11, 2015
    Last edited by a moderator: Oct 11, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    I wonder:

    1. Do you have pureFTPd calling the pure-upload script to scan all of your FTP uploads through CXS / Maldet / ClamAV?

    That will cause an increase in CPU/memory, but its a small price to pay to scan the uploads

    Do your uploading and pay attention to what is going on with respect to CXS / ClamAV / Maldet.

    2. You mention passive FTP. If you are using passive FTP, do you have passive FTP ports [and enough of them] opened up in your firewall and configured in pureftpd.conf?

    Almost sounds as if you don't have a passive port range set in /etc/pureftpd.conf -- Or you do but don't have those ports allowed in CSF.

    Ex:

    /etc/pureftpd.conf
    PassivePortRange 30000 35000

    /etc/csf/csf.conf
    TCP_IN = "20,21,22,25,26,53,80,110,113,143,443,465,587,967,993,995,2077,2078,2082,2083,2086,2087,2095,2096,30000:35000"

    I think with passive FTP, if you had no range set and you had no ports open, you wouldn't even get as far as you have. But it is worth checking to make sure you have PassivePortRange set and you have those ports allowed through CSF.

    M
     
  4. LaxSlash1993

    LaxSlash1993 Member

    Joined:
    Oct 8, 2015
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Buffalo, NY
    cPanel Access Level:
    Root Administrator
    I enabled PureFTPd and noticed a big improvement. The PassivePortRanges were enabled and opened as well.... if they weren't open, unless I'm wrong, I wouldn't be able to get a connection out of them period.

    I can't get Active working at all for whatever reason... I'm forced into using Passive mode. Ports are opened using --add-port=30000-50000/tcp and --add-service=ftp.
     
  5. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,281
    Likes Received:
    37
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    I think you'd establish a connection but couldn't list directories, change directories, or transfer files -- or some combination of that.

    In order for active to work, you have to make sure that TCP 20 and 21 are not blocked. But there is no reason to do that as passive works fine as long as configured properly.

    From the sound of it everything is working fine now since you switched to PureFTPd upon Michael's recommendation. I wouldn't be concerned that active mode isn't working.

    active uses TCP 20/21
    passive uses TCP 21 and (dynamically) the PassivePortRange

    M
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page