The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

:fail: failure (pun intended, but problem real)

Discussion in 'General Discussion' started by Ishware, May 25, 2004.

  1. Ishware

    Ishware Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Panama City, FL
    cPanel Access Level:
    Root Administrator
    Okay, I've been using WHM/cPanel for quite some time now...

    And during this time, I've gotten very used to being able to set forwarders to ":fail: (custom message)"...

    All of a sudden, it's not working anymore.

    When I use an external email address (i.e. hosted on a different server) to send email to an address on one of my domains set to forward to ":fail:", I do get a bounce, but it's changed. Now the bounce is:

    -------------------
    MailEnable: Message could not be delivered to some recipients.
    The following recipient(s) could not be reached:

    [SMTP:something@mydomain.com]: Remote SMTP Server Returned: 550-"The recipient cannot be verified. Please all recipients of this message

    550 to verify they are valid."
    ---------------------

    And when I try to send from an email address on my hosting (i.e. I have multiple domains), I get an error message in Outlook - it doesn't allow it to send from the outbox. Error there is:

    -------------------
    Task 'someemail@oneofmydomains.com - Sending' reported error (0x800CCC65) : 'Your outgoing (SMTP) e-mail server has reported an internal error. If you continue to receive this message, contact your server administrator or Internet service provider (ISP). The server responded: 503 valid RCPT command must precede DATA'
    -------------------

    When I contacted my host, they initially said ":fail: will only work for the default address". I pointed out to them that it had been working all this time... While I was typing this, I just heard back from them - now they say it was the latest cPanel update.

    What?

    1. If that's true, any chance it's a temporary issue?
    2. If that's not true... anything I might could tell my host on how to fix the issue? :)

    Man, I *depend* on this feature heavily... When I go to sign up for stuff on websites, I always sign up using the domain name as my email-user, i.e. if I go to yourdomain.com, I'd sign up using yourdomain.com@mydomain.com so I know if you spam me. :)

    I mean, it's not just a matter of doing the reverse - setting default to :fail: and opening up (forwarding to valid accounts) the ones I use -- the problem is, I don't remember what all I've used! Chances are great I'll miss emails if I have to just shut it all down.

    I would definately appreciate any advice and/or enlightenment anyone would care to share... :)

    Take care,
    -i
     
  2. Ishware

    Ishware Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Panama City, FL
    cPanel Access Level:
    Root Administrator
    So, it was an update?

    Does anyone have any ideas on why this happened?

    Hey, I flatly say that whereas I understand some things, and whereas I am a Windows geek, I am *not* a server geek. So I don't always understand why certain things are risks, but sometimes I do manage to comprehend... :)

    Was there some sort of security thing? Or was this because it was filling up mail queues, and that prompted a software-wide change or something?

    I must not be searching for the right terms - my host said there was conversation on this forum about this topic, but after doing a forum-wide search on "fail", I never managed to find anyone else talking about this...

    Hey, even a quick reply of someone saying "Yeah, the topic is being discussed, you just managed to miss it, dummy (to keep the theme from above going)", that'd be cool too... I'm not even asking for a link. Although if you take the time to reply, you might suggest a different keyword than "fail", since I did search on that already... heh.

    Yeah, I'm verbose. It's a geek thing. Deal. :)
     
  3. Jay

    Jay Member

    Joined:
    Aug 15, 2001
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here - did you find a solution to this?
     
  4. Ishware

    Ishware Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Panama City, FL
    cPanel Access Level:
    Root Administrator
    Well, I was told by my host that it was an update to cPanel that did it, but I never ever did find a thread on this forum that confirmed that...

    <shrug>

    OTOH, I was talking into switching over to using :blackhole:, which does work without giving the error...
     
  5. Jay

    Jay Member

    Joined:
    Aug 15, 2001
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    That was what I did as well...hopefully a fix will be released.
     
  6. Ishware

    Ishware Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Panama City, FL
    cPanel Access Level:
    Root Administrator
    Well... I dunno...

    Well, okay, yeah, I hope a fix is released to give us the option again, because I really like not being restricted... But it did force a conversation between my host and me, where it was pointed out that all these reflected virus failures and reflected spam failures (which are kinda becoming one and the same, sorta) have really changed the picture...

    Used to be, you wanted to let your sender know their message failed, so they could try and correct their error. But nowadays, most of what's coming in (in my experience at least) is the reflections of randomly generated spoofed email addresses - both from and to.

    I've managed to keep myself nearly spam free by using various techniques...

    1. When I go sign up for something, I usually generate an email address based on the site. For example, I would typically use cpanel.net@[mydomain.com] to sign up here for anything. So if I started to get spam, 1) I'd know who did it to me and 2) makes it easier to shut off...

    2. I don't use common addresses like webmaster@, info@, sales@, because they catch spam. At the moment, postmaster@ and abuse@ don't catch much, so I'm using those as long as I can - but if spammers start to hit those, I'll have to use another method, screw the RFC's. :)

    3. The [bleep]hole spammers harvest from the registry. So I use a rolling contact address, which I change every month or two (takes them time to hit me). Typically, I use the month/year, i.e. 0404@[mymasterdomain.ext]...

    Using those and a couple of other tricks, I get virtually no spam. The only major problem I had was leaving default address open, because I'd get massive influxes of reflected failures - which I would use :fail: on, like ":fail: This has never been a real email address - someone has spoofed it." or some such similar.

    But it was pointed out to me that chances are high that hits to those non-legit addresses would be sent back to non-legit addresses, and sticking in the mail queue for several days...

    This is becoming and more typical issue - the stuff that's stuck in the queues...

    So I've been converted to the next step in fighting spam...

    I've always felt that using :blackhole: meant I was implicitely accepting the email, whereas :fail: meant I was rejecting it. But now I've come to the conclusion that... screw it. :blackhole: is the way to go.

    You have to do things to protect your system, and this is just one of those things.

    Times have changed.

    But hey - I'm open to new ideas. If people have suggestions on better ways of doing things, lemme know. And if my postings here inspire someone, and help someone, so much the better.
     
  7. Ann

    Ann Member

    Joined:
    May 24, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Blackholing all my addresses is not an option for me. And what's more, I also need that custom message! An address I just retired is still catching a good deal of legitimate mail, and I need to tell them to go look for my new address. Even WHERE.

    OK, so I can blackhole some addresses, but not my very freshly retired ones. There's just no way. This MUST be changed.
     
  8. Ishware

    Ishware Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Panama City, FL
    cPanel Access Level:
    Root Administrator
    Workaround...

    Do you happen to be, like, a reseller or admin of your own domain? As in, more specifically... If you can set up another account in WHM, you can set up a subdomain. Make the default addy on the subdomain the appropriate fail (I have NOT tested this, but I was told that :fail: works for the default address only), then forward that email addy to the subdomain's default addy... You could even, to make it slightly more obscure, create the subdomain as "fail.yourdomain.com" or something...

    Yeah, it's not great, but if it works, hey... better than something that doesn't work...
     
  9. Ann

    Ann Member

    Joined:
    May 24, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    After checking the bounces, I realize that the change in handling fails, is that the bounces are now done BEFORE the mails are accepted by the mail server. That's plainly visible by the fact that these days it's my sending server (SMTP, quite often it's your ISP's mail server) that sends me the bounce message. That's why our custom fail messages won't be transmitted to the recipient.

    That's a superior system for handling viruses and spams, in that the sending mail server inherits the problem. There's no mail rattling around in an endless loop on the receiving system.

    At the same time, there's no way to notify your friends or business contacts of where your new address is (a page with a spam proof way of displaying your new address, of course). Considering quite a few users these days are even less than clueless, that's a loss.

    OK, back to the new way of handling fails:

    With this change in procedure, wouldn't it be better to fail retired addresses than blackhole them?

    Exactly what happens when mail from a nonexistent address is refused at that level? Does it rattle around someone's system indefinitely?
     
    #9 Ann, May 31, 2004
    Last edited: May 31, 2004
  10. Ishware

    Ishware Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Panama City, FL
    cPanel Access Level:
    Root Administrator
    That's a good point... In fact, if you send yourself a message to the failed address, it won't leave your outbox - the server rejects it.

    Judging from my own experience: It's not accepted by the server. So isntead of accepting the message and putting a return message in the queue, it simply doesn't accept it from the sending server. Since the sending server has most likely accepted it already from the end user, the sending server will probably send a message to the end user. That's what happened when I tested it from another server my dad runs (which is a Windows box running IIS, as it happens... It sent me a failure notice letting me know it couldn't send the message).

    I just came up with a method, though, that worked.

    1. Create an alias that you'll never use, and point it to blackhole. I used "messagefailureblackhole".
    2. Create a second alias (I called this one "messagefailure"), and:
    2a. Point it to alias from #1 (i.e. "messagefailureblackhole")
    2b. Create an autoresponder to detail your desired message. (i.e. "from: postmaster@domain.com subject: Your recent message... body: This email has been shut down...")
    3. Now, instead of ":fail:", use the alias from step 2 (in this case "messagefailure").

    That's if you want a system-wide setup with one failure message...

    If you want custom failure messages, then:

    1. Create a blackhole alias
    2. For each item you want to fail, create an alias to point it to the blackhole alias, AND create an autoresponder.

    (I tested just creating the autoresponder and pointing the alias itself to blackhole, but blackhole processes before the autoresponder, so the autoresponder doesn't.)

    At least it works. :)
     
  11. jdonoso

    jdonoso Well-Known Member

    Joined:
    Nov 15, 2004
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    The Third Rock from The Sun!
    This bug has never been fixed?? I'm currently having problems with this.

    Cpanel 9.9.8 Release 160
    Fedora Core 1


    Regards,
     
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    What problem are you having, exactly? This thread talks about a lot of things, most of them to do with how SMTP works and how some email clients don't (e.g. Outlook).
     
    #12 chirpy, Dec 3, 2004
    Last edited: Dec 3, 2004
  13. Ishware

    Ishware Well-Known Member

    Joined:
    Nov 7, 2003
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Panama City, FL
    cPanel Access Level:
    Root Administrator
    Uh, no, that's not what this thread talks about at all.

    It talks about some issues regarding ":fail:".

    Try reading it again in that light?

    Personally, I don't care about the issue, as I moved on - and in fact, I no longer :fail: anything, I *always* :blackhole:...

    But I was subbed to the thread, and at least if people are going to talk about it, they should be talking about the actual issue at hand... :p :p :p :)
     
  14. Z505

    Z505 Member

    Joined:
    Mar 5, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Similar problems here. There's no way one should have to go and set up another domain in WHM as a temporary hack work around. Come on, people are paying a large sum for Cpanel licenses... this isn't or should not be a "figure out a hack/workaround" situation.
     
    #14 Z505, Mar 5, 2005
    Last edited: Mar 5, 2005
  15. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    If you're having problem with these issues (and there are several mentioned here!) make sure that you only ever use :fail: and not :blackhole: (which really should be removed as an option) for all the reasons listed here:
    http://www.configserver.com/free/fail.html

    Additionally, if you want a fail message in the rejection you can just make a very simply change in exim.conf which I documented here:
    http://forums.cpanel.net/showthread.php?p=155578
     
    #15 chirpy, Mar 5, 2005
    Last edited: Mar 5, 2005
  16. jwilso37

    jwilso37 Registered

    Joined:
    Mar 13, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I'm having this same problem and am anxious for a resolution. :blackhole: works fine with forwarders, so I'm stumped as to why :fail: does not.
     
Loading...

Share This Page