The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fail is not working but blackhole does

Discussion in 'General Discussion' started by atomjax, Feb 18, 2009.

  1. atomjax

    atomjax Member

    Joined:
    Sep 4, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Last week I made a change to the exim config and I got this e-mail:



    cPanel was unable to automatically merge your Exim configuration with the new settings that shipped with the build you have installed (11.24.4-RELEASE_33472) because you have a custom ACL configuration which cannot be automatically configured.

    To avoid any mail downtime, we thought it was best to leave your previous configuration intact until the new configuration can be properly installed. In order to complete this configuration update, you will need to manually merge your configuration with the new configuration settings. Please follow the steps below to complete this update:

    1. Enter the Advanced Configuration Editor
    2. Notate any custom changes you have made in the ACL section.
    You may also which to make a copy of /etc/exim.conf.local
    and /etc/exim.conf.localopts as custom settings are contained in these files.
    3. Click the 'Reset ACL Config to Defaults' button.
    4. Reinstall your advanced custom settings.

    Note: Until you manually complete this update, automatic spam filtering may have been rendered inoperable to prevent any mail loss. (This generally only applied is you were upgrading from cPanel 10.x)

    Current Config Version: 3.900000
    New Config Version: 5.900000


    I had previously upgraded from 10 so this wasn't a surprise. So I backed up /etc/exim.conf.localopts (exim.conf.local didn't have any data in it.) and I followed the instructions. I clicked on the Reset ACL config to Defaults button and all was fine after that.

    That day I noticed that the queue started building up when it hadn't done this before. I am talking thousands of messages. Looking at the queue showed that it was all bounced spam messages. A spammer was trying to mail to users that didn't exist for a domain. I looked at the account it is set to fail.

    My understanding is that fail causes the sending mail server to send the rejected e-mail with a no person here message. Instead it looks like it is making my server send these rejection notices that are piling up in the queue.

    I set the default to discard (blackhole) the mail instead and this works fine. The mail actually blackholes. When I set it back to fail it starts piling up the messages in the queue again.


    This is what exim_mainlog looks like for a fail message

    2009-02-18 08:56:52 1LZon5-0004Tj-Ng ** vulcompendium@removeddomain.com R=virtual_aliases:
    2009-02-18 08:56:52 1LZon5-0004U6-TJ ** vubeat@removeddomain.com R=virtual_aliases:


    and this is what it looks like for a blackhole


    2009-02-18 10:56:29 1LZqeq-0002lV-PP => :blackhole: <zdstyrant@removeddomain.com> R=virtual_aliases
    2009-02-18 10:56:29 1LZqeq-0002lV-PP => :blackhole: <zdsthose@removeddomain.com> R=virtual_aliases


    I would rather use fail obviously if it worked. Any ideas on why it's not working?

    My version is cPanel 11.24.4-R33472


    Thanks

    Jason
     
Loading...

Share This Page