The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

failed cPanel upgrade

Discussion in 'General Discussion' started by erichthewebguy, Sep 24, 2006.

  1. erichthewebguy

    Joined:
    Sep 24, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hi. I just upgraded to the latest stable because of that exploit thing, and now cPanel just generates a blank page. The error from /usr/local/cpanel/logs/error_log shows:

    open3: exec of /usr/local/cpanel/cpanel ./frontend/rvblue/index.html failed at cpsrvd.pl line 733

    I have removed /usr/cpanel/cpanel and forced the update again, with the same result. Any thoughts?

    EDIT: During the upgrade, I did get a bunch of 404 errors:

    Error 404 while fetching url http://httpupdate.cpanel.net//cpanelsync/RELEASE/cpanel/strace
     
  2. merlinpa1969

    merlinpa1969 Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    PA
    cPanel Access Level:
    Root Administrator
    I thought everything upgraded but I have tons of errors now,
    fantastico has errors
    the lysql link dosnt show ANY of the databases
    Trying to run a backup causes tons of errors

    and now when we try to run the updater again its hanging up at
    This is the cPPkgs::MySQL 4.1.21 installer for Linux.
    MySQL 4.1.21 is up to date
     
  3. erichthewebguy

    Joined:
    Sep 24, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    OK, well I am installing the "CURRENT" tree and will se how that turns out. :D
     
  4. erichthewebguy

    Joined:
    Sep 24, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Try logging in to your server as root and running /scripts/upcp

    EDIT: This is getting weird. I replied to the post below and wound up above it. This is twice in a row. Odd!
     
  5. merlinpa1969

    merlinpa1969 Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    PA
    cPanel Access Level:
    Root Administrator
    I did that everything hung at the mysql update line then froze

    and now cpanel and whm are gone,
    I mean GONE
     
    #5 merlinpa1969, Sep 24, 2006
    Last edited: Sep 24, 2006
  6. erichthewebguy

    Joined:
    Sep 24, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I installed the CURRENT tree and it's working fine now. I installed the RELEASE tree before, and it failed.
     
  7. merlinpa1969

    merlinpa1969 Well-Known Member

    Joined:
    Dec 3, 2003
    Messages:
    108
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    PA
    cPanel Access Level:
    Root Administrator
    check and see if your databases are viewable in the mysql section of cpanel

    that and fantastico were my first 2 issues
     
  8. erichthewebguy

    Joined:
    Sep 24, 2006
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    my MySQL and Fantastico are working fine. I'm not sure what could be causing your issues, maybe incorrect permissions on some of your files?
     
  9. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Happens all the time now on their forums. Their forums are consistent with their codebase at least - buggy.
     
Loading...

Share This Page