frenziedfox

Well-Known Member
Mar 9, 2010
60
11
58
Hi,

Another random service down. This is one of my two name servers. This suddenly started:

Serverns2.xxx
Primary IP Addressx.x.x.x
Service Namecpanel_php_fpm
Service Statusfailed ⛔
NotificationThe service “cpanel_php_fpm” appears to be down.
Service Check MethodThe system’s command to check or to restart this service failed.
Number of Restart Attempts1
Service Check Raw Output(XID 2u755a) The “cpanel_php_fpm” service is down.

The subprocess “/usr/local/cpanel/scripts/restartsrv_cpanel_php_fpm” reported error number 255 when it ended.
Memory Information
Used475 MB
Available515 MB
Installed991 MB
Load Information0.01 0.03 0.02
Uptime5 minutes and 32 seconds
IOStat Informationavg-cpu: %user %nice %system %iowait %steal %idle 1.17 0.07 1.29 0.58 0.00 96.89 Device: tps kB_read/s kB_wrtn/s kB_read kB_wrtn sda 52.52 1848.65 86.21 610610 28476 dm-0 48.87 1810.35 80.01 597959 26428 dm-1 0.27 6.67 0.00 2204 0
Top Processes
PID
Owner
CPU %
Memory %
Command
798root0.120.17/usr/sbin/crond -n
1046cpanelconnecttrack0.070.26/usr/local/cpanel/3rdparty/sbin/p0f -i any -u cpanelconnecttrack -d -s /var/cpanel/userhomes/cpanelconnecttrack/p0f.socket less 400 and not dst port 80 and not dst port 443 and tcp[13] & 8==0
1099wp-toolkit0.063.87/usr/bin/sw-engine /usr/local/cpanel/3rdparty/wp-toolkit/bin/run-script background-tasks-executor.php
1095mysql0.048.23/usr/sbin/mysqld
1035root0.041.72/usr/bin/python2 -Es /usr/sbin/tuned -l -P
Configure Monitor Settings:
Configure chkservd:
Disable HTML notifications:
The system generated this notice on Wednesday, June 1, 2022 at 5:38:24 PM UTC.
“Service failures (ChkServd)” notifications are currently configured to have an importance of “High”. You can change the importance or disable this type of notification in WHM’s Contact Manager at: https://xxx:2087/scripts2/editcontact?event=chkservd
Do not reply to this automated message.
I thought it doesn't need cpanel_php_fpm? I compared it with ns1 which has no such error and it looks identical, there is no cpanel_php_fpm to disable/enable.

Also, anything in /scripts2 (like 'configure chkservd') you get Error 404.

Help!

Alex
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,032
1,741
363
cPanel Access Level
Root Administrator
Hey there! This is a known issue that we've talked about a bit here:


The case number mentioned on that page (CPANEL-40724) is the case open with our developers to address this issue, and we're working on that now.
 

martin MHC

Well-Known Member
Sep 14, 2016
267
62
78
UK
cPanel Access Level
Root Administrator
We also have this issue, or something very much like it, often occurring about 2am (quiet time for the server, doing backups etc.) but there seems no clear reasoning for it that I can see.

Code:
The service “cpanel_php_fpm” appears to be down. 

RAW notice (via email): (XID 2pbjbq) The service “cpanel_php_fpm” failed to send the expected response from the socket “/var/cpanel/php-fpm/cpanelphpmyadmin/sock” because of an error: The system failed to read a response from the service

The subprocess “/usr/local/cpanel/scripts/restartsrv_cpanel_php_fpm” reported error number 255 when it ended.