The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed dependencies problem [libmysqlclient.so.15]

Discussion in 'Database Discussions' started by chiefme, Apr 18, 2012.

  1. chiefme

    chiefme Member

    Joined:
    Jan 21, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello,
    I’m trying to install Sphinx:
    Code:
    # rpm -Uvh sphinx-2.0.4-1.rhel5.x86_64.rpm
    error: Failed dependencies:
            libmysqlclient.so.15()(64bit) is needed by sphinx-2.0.4-1.rhel5.x86_64
            libmysqlclient.so.15(libmysqlclient_15)(64bit) is needed by sphinx-2.0.4-1.rhel5.x86_64
    
    Googled and as suggestion found this link

    was trying to install what dependency:
    Code:
    # rpm -ivh ftp://mirror.switch.ch/pool/1/mirror/mysql/Downloads/MySQL-5.0/MySQL-shared-compat-5.0.95-1.rhel5.x86_64.rpm
    Retrieving ftp://mirror.switch.ch/pool/1/mirror/mysql/Downloads/MySQL-5.0/MySQL-shared-compat-5.0.95-1.rhel5.x86_64.rpm
    Preparing...                ########################################### [100%]
            file /usr/lib64/libmysqlclient.so from install of MySQL-shared-compat-5.0.95-1.rhel5.x86_64 conflicts with file from package MySQL-shared-5.1.61-0.cloud.x86_64
            file /usr/lib64/libmysqlclient_r.so from install of MySQL-shared-compat-5.0.95-1.rhel5.x86_64 conflicts with file from package MySQL-shared-5.1.61-0.cloud.x86_64
    
    
    What im doing wrong? Please, can someone help me to resolve this issue?


    My server info:
    mysql Ver 14.14 Distrib 5.1.61, for unknown-linux-gnu (x86_64) using readline 5.1
    WHM 11.32.2 (build 18)
    CENTOS 5.5 x86_64
     
Loading...

Share This Page