gilankpam

Registered
Aug 30, 2011
1
0
51
cPanel Access Level
Root Administrator
Code:
[email protected] # rpm -ivh http://www.simplescripts.com/vault/download/cpanel-latest.rpm
Retrieving http://www.simplescripts.com/vault/download/cpanel-latest.rpm
error: Failed dependencies:
        perl(CGI) is needed by simplescripts-cpanel-1.1-1.noarch
im running cpanel on centos 6
please help
thanks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello :)

That appears to be a third-party application, so ideally you should contact their support team so they can adjust their installer for CentOS 6 systems.

In the meantime, you may be able to resolve the issue by installing the perl-CGI package via:

Code:
# yum install perl-CGI
Thank you.
 

reynomit

Registered
Feb 1, 2012
2
0
51
cPanel Access Level
Root Administrator
Really simple fix for this if others are wondering...

This worked on a centos 6 system and all you need to do is:
Code:
rpm -ivh http://www.simplescripts.com/vault/download/cpanel-lat est.rpm --nodeps
This should work and you`ll be able to continue with the simplescript steps!
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
38
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
You probably do need the dependencies, though, since there would a reason those dependencies are required.

To install a perl rpm, you'd have to remove the perl* exclusion in /etc/yum.conf file before trying to install the script. After you get the script to install with the required dependencies, you'd then re-add the perl* exclusion into /etc/yum.conf file again.