The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed: sshd after /upcp

Discussion in 'General Discussion' started by kernow, May 8, 2013.

  1. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Were getting emails about sshd failing on several of our servers, this started shortly after upcp ran. Anyone else having same?
     
    #1 kernow, May 8, 2013
    Last edited: May 8, 2013
  2. ES - George

    ES - George Well-Known Member
    PartnerNOC

    Joined:
    Jun 12, 2011
    Messages:
    142
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Not seen this on any of our boxes before. Have you tried restarting SSH?
     
  3. Veeble-Adam

    Veeble-Adam Active Member

    Joined:
    May 7, 2013
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Sounds strange. Anything in the logs?

    You may try a forceful upcp. /scripts/upcp --force
     
  4. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    We did try a restart of sshd but it didn't fix the problem, its occurring on a few boxes. However ssh is not failing as we can login at any time and on two boxes we have left top -s running during the ssh failure emails. Interestingly the cpanel service email contains a line giving the number of restarts attempted and this matches the number of emails received, so the first email said ssh failed with one restart attempted and the 27th email says restarts attempted 27 etc.
    The logs contain the same info the email does, ie ;
     
  5. MTBiker

    MTBiker Registered

    Joined:
    May 8, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I've also started receiving these email since last night :( but SSH is working fine :)

    I've restarted the ssh service using "service sshd restart" and it restarts fine, in cpanel I get this error:

    I restarted the server and also tried "/scripts/upcp --force" but made no difference.

    Here is the email I receive:
    I also love the my server is "automagically" restarted and not "automatically", sounds like there is magic involved ;)
     
  6. tommy_pap

    tommy_pap Registered

    Joined:
    May 8, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I am having the same problem since last nights update.

    I am also getting "The security token is missing from your request." error when refreshing a WHM Login or WebMial Login.
     
  7. ochlocracy

    ochlocracy Registered

    Joined:
    Oct 18, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Another one with the same issue. Started getting sshd FAILED texts in the middle of the night, likely after upcp ran.

    sshd is running fine. Disabled monitoring in the meantime.

    additional info:
    It's reporting the failure with the primary IP, but we run sshd on a single IP that is not the primary server IP. We also moved it from port 22. If this is related to anyone else's issues. csf+lfd is also on this server, therefore controlling access to sshd via the ip and port.
     
    #7 ochlocracy, May 8, 2013
    Last edited: May 8, 2013
  8. schoeps

    schoeps Well-Known Member

    Joined:
    Sep 22, 2004
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Getting the same messages on 2/5 of our servers, should we wait for a patch?
     
  9. CitizenK

    CitizenK Well-Known Member

    Joined:
    Jun 5, 2012
    Messages:
    64
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    On The Road
    cPanel Access Level:
    Root Administrator
    Can you please try adding this line above any deny rules in WHM Home »Security Center »Host Access Control to see if whitelisting Local connections resolves this issue.

    sshd LOCAL allow
    sshd 127.0.0.1 allow

    If LOCAL is not whitelisted the ssh connection in the chksrvd test will fail because localhost will not be able to connect to the ssh server if you have an 'sshd ALL deny' rule in Host Access Control.

    Please then wait 5 minutes to allow for chksrvd checks to re-run, and then check the 'Server Status' page to verify the sshd check ran successfully.

    Please let us know if this resolves your issue.

    Thanks!
     
    #9 CitizenK, May 8, 2013
    Last edited: May 8, 2013
  10. MTBiker

    MTBiker Registered

    Joined:
    May 8, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks cpCitizenK, that tip works for me :)
     
  11. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    White listing LOCAL was never needed before, what changed in the last /upcp ?
     
  12. schoeps

    schoeps Well-Known Member

    Joined:
    Sep 22, 2004
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    worded on one, not the other
     
  13. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Nope, the suggested fix from cpCitizenK has not worked for us :(
     
  14. CitizenK

    CitizenK Well-Known Member

    Joined:
    Jun 5, 2012
    Messages:
    64
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    On The Road
    cPanel Access Level:
    Root Administrator
    Previously chksrvd ssh check only checked for sshd in the process list. In 11.38 cPanel is now attempting to make a connection to the sshd service to ensure that the service is up. Because of this if you have an deny all statement in your host access control without whitelisting local connections, host access control is blocking the chksrvd sshd check in some cases.

    If the above fix did not work for you can you please open a ticket using the ticket link in my signature and post your ticket number here so we can investigate this issue further. In your support ticket make sure to reference this forum thread.

    Thanks,
     
    #14 CitizenK, May 8, 2013
    Last edited: May 8, 2013
  15. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Ticket # 4089155
     
  16. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    OK, fixed thanks to cpanel tech Juan-Carlos Newton. Make sure to add to /etc/hosts.allow:
    sshd : 127.0.0.1 : allow
    sshd : local : allow
     
  17. schoeps

    schoeps Well-Known Member

    Joined:
    Sep 22, 2004
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    This worked
     
Loading...

Share This Page