Failed to access DBM file

otakudes

Member
Jun 19, 2020
17
4
3
USA
cPanel Access Level
Website Owner
I have installed Imunify360 and started getting these errors. I installed suPHP months ago and screwed up my permissions. I am using cPanel's default cgi for PHP. I thought this might have something to do with it.

Code:
 [Thu Dec 10 12:51:21.481305 2020] [:error] [pid 24324] [client xxx.xxx.xxx:6675] [client xxx.xxx.xxx.6675] ModSecurity: collections_remove_stale: Failed to access DBM file "/var/cpanel/secdatadir/mydomain-ip": Permission denied [hostname "www.mydomain.com"] [uri "/webpage.htm"] [unique_id "X9IZyWf-sa-C8XpPDPHgwgAAAAQ"], referer: https://www.google.com/


Code:
[[email protected] secdatadir]# ls -la
total 12
drwxrwx--T.   2 root   nobody   98 Dec 10 12:00 .
drwx--x--x. 107 root   root   8192 Dec 10 12:37 ..
-rw-r-----.   1 nobody nobody    0 Dec 10 12:00 nobody-global.dir
-rw-r-----.   1 nobody nobody    0 Dec 10 12:00 nobody-global.pag
-rw-r-----.   1 nobody nobody    0 Dec 10 12:00 nobody-ip.dir
-rw-r-----.   1 nobody nobody    0 Dec 10 12:00 nobody-ip.pag
I changed user and usergroup to root, and created the file it was looking for but the error persists.
 
Last edited by a moderator:

otakudes

Member
Jun 19, 2020
17
4
3
USA
cPanel Access Level
Website Owner
I'd like to use suPHP but don't know how to install it properly. So I'm using mod_cgi, mod_ruid2, and mod_mpm_prefork. I think it's the default cPanel setup.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
5,552
705
313
cPanel Access Level
Root Administrator
You can switch the PHP handlers by making sure they are installed in EasyApache, and then using the MultiPHP Manager interface in WHM. More details on that can be found here:

 

otakudes

Member
Jun 19, 2020
17
4
3
USA
cPanel Access Level
Website Owner
Thanks. Set up SuPHP one of my servers and seems to be working fine. Disappointed to find out suPHP is no longer supported. I haven't seen the error appear again on that server. As far as my other servers using mod_cgi, I read disabling jailed shell solves the issue. I'll just disable shell access. I don't use often.