Failed to create session: Failed to activate service 'org.freedesktop.login1': timed out

keat63

Well-Known Member
Nov 20, 2014
1,916
263
113
cPanel Access Level
Root Administrator
The server has performed an update recently and appears is now in need of a re-boot (this is why I'm not fond of auto-updates)
I'm seeing tons of these errors echoed in var/log/lfd.log and assume it's related, so I'll be performing the reboot out of hours.


Code:
Nov 18 13:00:26 xxxxxxx crond[25540]: pam_systemd(crond:session): Failed to create session: Failed to activate service 'org.freedesktop.login1': timed out
Nov 18 13:01:26 xxxxxxx crond[25949]: pam_systemd(crond:session): Failed to create session: Connection timed out
Any ideas what these relate to ?

I also had problems accessing the server via SFTP this morning, maybe also related ??
 
Last edited:

WasChristine

Technical Analyst
Aug 10, 2018
57
11
83
Houston, TX
cPanel Access Level
Root Administrator
The server has performed an update recently and appears is now in need of a re-boot (this is why I'm not fond of auto-updates)
I'm seeing tons of these errors echoed in var/log/lfd.log and assume it's related, so I'll be performing the reboot out of hours.


Code:
Nov 18 13:00:26 xxxxxxx crond[25540]: pam_systemd(crond:session): Failed to create session: Failed to activate service 'org.freedesktop.login1': timed out
Nov 18 13:01:26 xxxxxxx crond[25949]: pam_systemd(crond:session): Failed to create session: Connection timed out
Any ideas what these relate to ?

I also had problems accessing the server via SFTP this morning, maybe also related ??
Hello,

This issue generally loops back to the systemd-logind service. The service could experience problems for various reasons. A user in this thread mentioned that it may be caused by the number of files generated in /run/systemd/system though this may not necessarily be the cause of your issue.

That said, a planned reboot would address the issue since it would go through and restart systemd-logind anyways. Could you let us know if this helps at all?
 

keat63

Well-Known Member
Nov 20, 2014
1,916
263
113
cPanel Access Level
Root Administrator
The server performed an automated update which required a reboot (yellow - please reboot banner)
The reboot seems to have resolved the issue.

I don't like auto updates for this exact reason.
If I have to connect out of hours to perform a reboot, I might as well connect out of hours to perform the update.
It doesn't save any time.

I rebooted it last night, it's performed another update at 4am, so I'll have to reboot it again tonight.
 

WasChristine

Technical Analyst
Aug 10, 2018
57
11
83
Houston, TX
cPanel Access Level
Root Administrator
Greetings,

Thank you for getting back to us.

You could disable updates manually through the cpupdate.conf file, though the yellow banner requesting update will only occur if there are packages that have updated that require reboots to complete. So any time that you receive output from this command, you should consider rebooting:

Code:
needs-restarting -r
I have a test server running that has not been rebooted in some time, so I could use it as an example for you here:
Code:
[[email protected] ~]# needs-restarting -r
Core libraries or services have been updated:
  linux-firmware -> 20191203-76.gite8a0f4c.el7
  dbus -> 1:1.10.24-14.el7_8
  glibc -> 2.17-307.el7.1
  systemd -> 1:219-73.el7_8.9.cloudlinux

Reboot is required to ensure that your system benefits from these updates.

More information:
https://access.redhat.com/solutions/27943
That said, we are glad to see that you were able to address the original problems in systemd-logind.