The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed to create subdirectories error

Discussion in 'EasyApache' started by nikomaxia, May 30, 2016.

Tags:
  1. nikomaxia

    nikomaxia Registered

    Joined:
    May 6, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens
    cPanel Access Level:
    Root Administrator
    Hi there!!
    I get a huge amount of errors from apache:

    ModSecurity: Audit log: Failed to create subdirectories: /usr/local/apache/logs/modsec_audit/nobody/20160530/20160530-1505 (Permission denied) [hostname "www.xxxxxxxx.com"] [uri "xxxx.php"] [unique_id "xxxxxxxxxxxxxxxx"]

    I'm running apache 2.4.18 on CentOS and php 5.6.x

    Is this a critical error?
    Does this error have effect on server security?

    I notice that, when I'm in /usr/local/apache/logs there are no folders named modsec_audit/nobody
    Do I have to create them by my own? What permission should I give to those folders?

    Thanks!!!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Please post the output from the following command:

    Code:
    httpd -M | grep security
    Also, have you recently updated to EasyApache 4, or are you using Mod_Ruid2 on this system?

    Thank you.
     
  3. nikomaxia

    nikomaxia Registered

    Joined:
    May 6, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens
    cPanel Access Level:
    Root Administrator
    Hi cPanelMichael and thanks for the reply. I ran the command and the result was
    security2_module (shared)
    I m also running easy apache 3 and I have enabled Mod_Ruid2 from easy apache
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    You are likely encountering a compatibility issue with Mod_Security and Mod_Ruid2, or MPM-ITK if it's enabled. The other option that might lead to these types of messages is found under the "Security" tab in "WHM >> Tweak Settings":

    "EXPERIMENTAL: Jail Apache Virtual Hosts using mod_ruid2 and cPanel® jailshell."

    The compatibility issue is documented at:

    Apache Module: ModSecurity - EasyApache 4 - cPanel Documentation

    You can find additional discussion of this issue on the following thread:

    ModSecurity: Rule processing failed.

    Thank you.
     
  5. nikomaxia

    nikomaxia Registered

    Joined:
    May 6, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens
    cPanel Access Level:
    Root Administrator
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page