The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed to find user "system"

Discussion in 'General Discussion' started by kernow, Jan 15, 2015.

  1. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Been getting the following for a couple days:
    Code:
    /var/log/exim_paniclog:
    2015-01-15 05:14:24 Failed to find user "system" from expanded string "${lookup{$domain}lsearch* {/etc/userdomains}{$value}}" for the virtual_aliases_nostar router
    2015-01-15 05:21:37 Failed to find user "system" from expanded string "${lookup{$domain}lsearch* {/etc/userdomains}{$value}}" for the virtual_aliases_nostar router
    Have tried the following to find;
    Code:
    grep ": system" /var/cpanel/users/*
    But it returns empty. Also ran:
    Code:
    /scripts/updateuserdomains
    
    But no luck. Any ideas please?
     
    #1 kernow, Jan 15, 2015
    Last edited: Jan 15, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    652
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you able to reproduce the error message through a delivery attempt, or is it simply an entry you notice in the log file? Feel free to open a support ticket using the link in my signature if you want us to take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  3. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Hi,
    We tracked this down to a domain name which is not owned by any user. It has a DNS entry though and as its not owned by any user its owned by the "system". It seems any time mail is sent to *@this_domain.com it causes the error. We need to keep the DNS entry so how can we avoid the errors being generated?
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    652
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You should create an account for the domain name if you plan to use it for email. Otherwise, ensure it's in /etc/remotedomains instead of /etc/localdomains so that it's email is not handled by the cPanel server.

    Thank you.
     
  5. kernow

    kernow Well-Known Member

    Joined:
    Jul 23, 2004
    Messages:
    865
    Likes Received:
    9
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    It shouldn't receive any mail which is why its owned by the system. Removing the entry from /etc/localdomains might do the trick though, thanks.
     
  6. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I've just seen the same error today.
    Checking the mail logs, it seems someone sent an email to thisisnotarealemail@myserverhostname.com
    I can recreate this by sending an email to the domain also.

    This domain isn't owned by anyone, and is purely there to act as a name server and hostname.
    The domain is highly unlikely to ever send email, other than the server it's self.
    If i cut the entry from localdomains and add it to remotedomains, do i need to restart any services.
    The DNS also has an MX entry for the domain, is it OK to remove this without affecting any of the domains which do have user accounts ?
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I believe your issue to be different. See if this setting is enabled:
    Home » Service Configuration » Exim Configuration Manager, ACL Options tab

     
  8. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    The feature was indeed switched off.
    I've enabled this feature, and restarted exim, but the error still occurs if i send an email to the domain
     
  9. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    652
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please review the following post and let us know if those steps help.

    Thank you.
     
  10. keat63

    keat63 Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    765
    Likes Received:
    20
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    I ran grep ": system" /var/cpanel/users/* and it comes back with no results
     
  11. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    652
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.
     
Loading...

Share This Page