The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed to install CPAN Perl module(s) Crypt PasswdMD5

Discussion in 'EasyApache' started by ellan, Oct 7, 2014.

  1. ellan

    ellan Member

    Joined:
    Oct 7, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hello. I have this dedicated server.

    CENTOS 5.11 i686 standard – server WHM 11.44.1 (build 18)

    I updated apache, cpanel, I think it was /script/upcp

    Then I entered easyapache to add mod_deflate to my server. I add it and the apache is starting to rebuild. Then I get this error while building:

    Code:
    !! Failed to install CPAN Perl module(s) Crypt::PasswdMD5 !!
    I tried all the codes found in this forum and around the net to fix this, nothing works.

    I can provide pictures, and try any code you send.

    Host sent me here to solve this problem so you are the only one can help. I am sorry for eventual bumps, but really I want this solved. Thank you for help.
     
  2. John

    John Active Member

    Joined:
    Jan 1, 2014
    Messages:
    25
    Likes Received:
    2
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Try running below command,

    +++
    /usr/bin/perl -MCPAN -e 'install Crypt::PasswdMD5'
    +++

    Ref: Easy Apache failed error
     
  3. ellan

    ellan Member

    Joined:
    Oct 7, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    root@server [~]# /usr/bin/perl -MCPAN -e 'install Crypt::PasswdMD5'
    Attempt to free unreferenced scalar: SV 0x863440c, Perl interpreter: 0x8516008 a t /usr/lib/perl5/5.8.8/ExtUtils/Liblist.pm line 6.
    Segmentation fault (core dumped)
    root@server [~]#
     
  4. ellan

    ellan Member

    Joined:
    Oct 7, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    John, I did :

    Code:
    root@server [~]# /usr/bin/perl -MCPAN -e 'install Crypt::PasswdMD5'
    Attempt to free unreferenced scalar: SV 0x863440c, Perl interpreter: 0x8516008 a                                     t /usr/lib/perl5/5.8.8/ExtUtils/Liblist.pm line 6.
    Segmentation fault (core dumped)
    root@server [~]#
    before tried also:

    Code:
    root@server [~]# /usr/bin/perl -MCPAN -e 'install Crypt::PasswdMD5'
    Attempt to free unreferenced scalar: SV 0x8a7840c, Perl interpreter: 0x895a008 at /usr/lib/perl5/5.8.8/ExtUtils/Liblist.pm line 6.
    Segmentation fault (core dumped)
    
    root@server [~]# /usr/local/cpanel/bin/cpanm -n Digest::SHA1 Crypt::PasswdMD5
    Attempt to free unreferenced scalar: SV 0x98ef064, Perl interpreter: 0x9846008 at /loader/0x98ee974/App/cpanminus/script.pm line 7.
    Undefined subroutine called at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/Fcntl.pm line 234.
    Compilation failed in require at /usr/lib/perl5/5.8.8/File/Temp.pm line 137.
    BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/File/Temp.pm line 137.
    Compilation failed in require at /loader/0x98ee974/App/cpanminus/script.pm line 11.
    BEGIN failed--compilation aborted at /loader/0x98ee974/App/cpanminus/script.pm line 11.
    Compilation failed in require at /usr/local/cpanel/bin/cpanm line 20668.
    BEGIN failed--compilation aborted at /usr/local/cpanel/bin/cpanm line 20668.
    
    root@server [~]# /scripts/perlinstaller Crypt::PasswdMD5
    Attempt to free unreferenced scalar: SV 0x94e1510, Perl interpreter: 0x93f9008 at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO/File.pm line 134.
    Segmentation fault (core dumped)
    root@server [~]#
    I noticed that I have in Install a Perl Module

    Location of Your Perl Module(s)
    Path: /usr/lib/perl5


    in httpd.conf lines 132-135

    Code:
    <IfModule mime_module>
        TypesConfig conf/mime.types
        AddType application/x-compress .Z
        AddType application/x-gzip .gz .tgz
    I have Gzip page compression [?] On - in WHM.

    When I click build apache I see I have already checked the Deflate [ More Info ↑ ] ? That was unchecked before starting the first time i rebuild. after i get errors and went back to rebuild i see it checked. I leave it checked, i go on and build and perl error appear.

    i don't see though mod deflate on server as module, see pics. httpd -M ( cpanel2.png )

    Is possible for the mod_deflate to be installed, me trying to rebuild... but i don't change anything, since i see DEFLATE checked already now and the error pop up ?

    At first I had to update my cpanel because i got this error that update fixed it.

    "Main - Software - EasyApache (Apache Update)" but I get this error:

    Code:
    Internal Server Error
    500
    No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/easyapache.pl) with exit signal: 2
    then I had loggin in again in WHM above shows : "The last attempt to update cPanel & WHM was blocked. Click here for details."

    Code:
    Please correct these issues and rerun updates.
    fatal: Upgrade is blocked because EXIMUP is set to 'never' in your configuration. To proceed, you can touch file '/var/cpanel/exim.unmanaged' and run the upgrade one more time. Please refer to our documentation at [url]http://go.cpanel.net/1136UpgradeExim[/url] for more information.
    Then again, in easy apache I got Internal Server Error 500... so I update dcpanel, fixed the EMIMUP using some code around and then i have the PERL ISSUE when adding deflate...
     

    Attached Files:

  5. ellan

    ellan Member

    Joined:
    Oct 7, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thank you, it worked! You made my day... :)

     
Loading...

Share This Page