The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed to install SSL certificate, error: connection reset

Discussion in 'General Discussion' started by ningning.wang, Nov 27, 2012.

  1. ningning.wang

    ningning.wang Registered

    Joined:
    Nov 27, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hey, I need some help with SSL certificate installation.

    This is what "Show IP Address Usage" shows
    101.0.74.51 srv.domain1
    101.0.74.48 domain2 domain1

    I have *successfully* installed SSL certificate for domain2 via "Install a SSL Certificate and Setup the Domain" with the following setting

    domain: domain2
    user: nobody
    IP: 101.0.74.48

    Note:

    If I set user to the comics, it failed to install the certificate with error "You need a dedicated IP address... or change user to nobody". I'm not too sure whether I've been assigned a dedicated IP address. How do I find out?

    It allowed me to install the certificate with user nobody but https://domain2 is not working. The error is "connect reset".

    I've tried to turn the installed certificate to shared certificate but it didn't help.

    I'm not sure what I have missed. It will be great if anyone could give me some ideas.
     
  2. bbrink68

    bbrink68 Active Member

    Joined:
    Nov 27, 2012
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    Hello,

    To install an SSL for a domain it will need its own up address, you can find this out in "show IP usage" section. If a site has their own IP no other domains will be listed as using that ip.

    Your host should be able to assign you more IPs if you need them, also WHM has a feature called "change sites IP" if you need to move a site to a new IP just keep in mind DNS changes will need to be made as well!

    Good Luck!
     
  3. ningning.wang

    ningning.wang Registered

    Joined:
    Nov 27, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you for your reply, bbrink.

    I've moved the site to a dedicated IP address. "show IP usaeg" shows

    IP1: srv.domain1, domain2
    IP2: domain1

    I've re-installed the SSL certificate for domain2 with the new IP address IP1 but the https site still returns connection reset.

    Any help would be appreciated.
     
Loading...

Share This Page