Failed to load require module for make the upgrade to 11.94.0.4

[email protected]

Well-Known Member
Aug 3, 2016
63
5
58
Everywhere
cPanel Access Level
Root Administrator
Hello,

The system can't make automatically the update from 11.92.0.12 to 11.94.0.4 due to a "strange" error! This is the error:

Code:
Failed to load a required module for this blocker. Skipping. (Error was: Can't locate cPanel/APIClient.pm in @INC (you may need to install the cPanel::APIClient module) (@INC contains: /usr/local/cpanel /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/530/lib/perl5/5.30.0/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/530/lib/perl5/5.30.0 /opt/cpanel/perl5/530/site_lib/x86_64-linux-64int /opt/cpanel/perl5/530/site_lib) at (eval 45) line 1.
I don't want to force the update because the above error makes me thinking that could be a disaster.

Can anyone had this issue? The above issue began the day that new version was publicly release for upgrade.

How we can resolve so the upgrade go smoothly? Is a new cPanel bug?
 

kodeslogic

Well-Known Member
Apr 26, 2020
331
126
118
IN
cPanel Access Level
Root Administrator
The error shared doesn't tell much about what would have caused this, please share more logs from /var/cpanel/updatelogs/updated.{TIMESTAMP}.log file.
 

cPDavidL

Linux Analyst II
Oct 15, 2012
79
18
133
cPanel Access Level
Root Administrator
Greetings!

The error you posted simply indicates a tool used by the update process is missing. Unfortunately, the snippet shared does not point out which module is missing, which is needed to advise you on a resolution.

As mentioned by kodeslogic, more information will need to be acquired from the update log. If you need help acquiring that additional information, please feel free to open a ticket with our support staff: cPanel
 

[email protected]

Well-Known Member
Aug 3, 2016
63
5
58
Everywhere
cPanel Access Level
Root Administrator
Hello, first of all thanks for the replies. The errors that I have every single day for about 2 weeks (when the attempts to upgrade to the new version began) are:

Code:
Running version '11.92.0.12' of updatenow.
Detected version '11.92.0.12' from version file.
Target version set to '11.94.0.4'
Switching to version 11.94.0.4 of updatenow to determine if we can reach that version without failure.
Retrieving and staging /cpanelsync/11.94.0.4/cpanel/scripts/updatenow.static.bz2
Using mirror '185.53.12.144' for host 'httpupdate.cpanel.net'.
Successfully verified signature for cpanel (key types: release).
Become an updatenow.static for version: 11.94.0.4
----------------------------------------------------------------------------------------------------
Running version '11.94.0.4' of updatenow.
Detected version '11.92.0.12' from version file.
Target version set to '11.94.0.4'
Checking license
License file check complete
Checking that the RPM DB is OK...
glibc-2.17-323.el7_9.x86_64
OK: RPM DB is responding to queries
Testing if rpm_is_working RPM is installed
package rpm_is_working is not installed
Testing if it's possible to install a simple RPM
Preparing...                          ########################################
Updating / installing...
rpm_is_working-1.0-0                  ########################################
LiteSpeed version check is complete

Failed to load a required module for this blocker. Skipping. (Error was: Can't locate cPanel/APIClient.pm in @INC (you may need to install the cPanel::APIClient module) (@INC contains: /usr/local/cpanel /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/530/lib/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/530/lib/perl5/5.30.0/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/530/lib/perl5/5.30.0 /opt/cpanel/perl5/530/site_lib/x86_64-linux-64int /opt/cpanel/perl5/530/site_lib) at (eval 45) line 1.

)
E Blocker found: Upgrade to the next 11.94 build is blocked in order to gradually distribute upgrades over multiple days. If you wish to upgrade now, you can do so by executing ‘/usr/local/cpanel/scripts/upcp --force’ via SSH or ‘WHM → Home → Server Configuration → Terminal’
W An attempt to upgrade to 11.94.0.4 was blocked. Please review blockers.
E The install encountered a fatal error: An attempt to upgrade to 11.94.0.4 was blocked. Please review blockers.
=> Log closed
...
And at the end of the /var/cpanel/updatelogs/update.{TIMESTAMP}.log
Code:
=> Log opened from cPanel Update (upcp)
Pre Maintenance completed successfully
95% complete
Running Standardized hooks
100% complete
cPanel update completed
A log of this update is available at /var/cpanel/updatelogs/update.{TIMESTAMP}.log
Removing upcp pidfile
W NOTE: A system upgrade was not possible due to the following blockers:
W [INFO] - Upgrade to the next 11.94 build is blocked in order to gradually distribute upgrades over multiple days. If you wish to upgrade now, you can do so by executing ‘/usr/local/cpanel/scripts/upcp --force’ via SSH or ‘WHM → Home → Server Configuration → Terminal’
=> Log closed
In this post seems the error is the same but noticed after upgrade I think. --> 94.0.4 update error question

I run this also with no luck:
Code:
/scripts/check_cpanel_rpms
Any idea what stop the upgrade? Never before had that issue with the versions upgrade of cPanel.

It's a bug or what?

Thank you.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,491
1,008
313
cPanel Access Level
Root Administrator
That message is just letting you know that the update will happen later on, as we try and distribute the updates so not every server updates on the same day.

If you run "/scripts/upcp --force" on the system I would expect that to work well. Can you try that and see if that gets you the update?