Failed to migrate /opt/cpanel/ea-php53/root/etc/php.d/local.ini

bloatedstoat

Well-Known Member
Jun 14, 2012
183
24
68
Victoria, Australia
cPanel Access Level
Root Administrator
Hello,

Having recently upgraded to v74.0.5 on Cloudlinux 6.10 we're seeing some errors during upcp.

"Failed to migrate /opt/cpanel/ea-php53/root/etc/php.d/local.ini to /opt/cpanel/ea-php53/root/etc/php.ini. This will need done manually."

I ran the script again via the cli and it spits out
Code:
Processing ea-php53 …
        Ignoring invalid directive “ifx.byteasvarchar”
        Ignoring invalid directive “ifx.charasvarchar”
        Ignoring invalid directive “ifx.textasvarchar”
        Ignoring invalid directive “ifx.max_persistent”
        Ignoring invalid directive “ifx.default_host”
        Failed to migrate /opt/cpanel/ea-php53/root/etc/php.d/local.ini to /opt/cpanel/ea-php53/root/etc/php.ini. This will need done manually.
        Error: (XID 9z7arn) 9 errors occurred:
                Error #1: “register_globals” is not a valid directive for PHP version “5.3.29”.
                Error #2: “ifx.max_links” is not a valid directive for PHP version “5.3.29”.
                Error #3: “ifx.default_password” is not a valid directive for PHP version “5.3.29”.
                Error #4: “ifx.allow_persistent” is not a valid directive for PHP version “5.3.29”.
                Error #5: “ifx.default_user” is not a valid directive for PHP version “5.3.29”.
                Error #6: “ifx.nullformat” is not a valid directive for PHP version “5.3.29”.
                Error #7: “ifx.blobinfile” is not a valid directive for PHP version “5.3.29”.
                Error #8: “magic_quotes_gpc” is not a valid directive for PHP version “5.3.29”.
                Error #9: “zend.ze1_compatibility_mode” is not a valid directive for PHP version “5.3.29”.
 … done!
I realise PHP5.3 is well and truly deprecated and we actually have no clients running under that PHP version.

Is the fix for this simply to copy /opt/cpanel/ea-php53/root/etc/php.d/local.ini to /opt/cpanel/ea-php53/root/etc/php.ini?

In the longer term I suspect running EA4 to compile a new build without 5.3 would remedy this permanently?

Thanks for any insight.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hi @bloatedstoat



Is the fix for this simply to copy /opt/cpanel/ea-php53/root/etc/php.d/local.ini to /opt/cpanel/ea-php53/root/etc/php.ini?
Based on the error it appears so, do you continue to receive the error once it's moved?

In the longer term I suspect running EA4 to compile a new build without 5.3 would remedy this permanently?
It should seeing as php53 isn't actually available by default through EasyApache 4 any longer just PHP 5.4 -> PHP 7.2

Thanks!
 

bloatedstoat

Well-Known Member
Jun 14, 2012
183
24
68
Victoria, Australia
cPanel Access Level
Root Administrator
Hello @cPanelLauren

Thank you. If I manually copy the file across the error persists.

As for the easy Apache thing. We use Cloud Linux selector and we have versions from 4.4 (yes 4.4!) although nothing runs under it and we have it disabled anyway, upwards to 7.2.

When I progress through the screens to compile a new build via EA4 it says that 7.2 isn't even installed yet we have sites actively running it via the CL selector mentioned above.

Have to admit I'm a bit confused now with EA4, Cloud Linux PHP Selector and cPanel's implementation.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,271
313
Houston
Hi @bloatedstoat

When I progress through the screens to compile a new build via EA4 it says that 7.2 isn't even installed yet we have sites actively running it via the CL selector mentioned above.
Keep in mind cPanel PHP 7.2 (ea-php) is different than CL Selector PHP 7.2 (altphp). Which might be why it says it's not installed. You could probably confirm this by running something like:

Code:
rpm -qa |grep ea-php72
No output would mean you don't have it installed

Running both CloudLinux PHP Selector and cPanel's MultiPHP you'll end up with two methods to change PHP versions and separate PHP versions for each. Both features essentially do the same thing, the PHP Selector just includes much older EoL PHP versions.

Thanks!