Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

fantasico from outside cpanel

Discussion in 'General Discussion' started by Promanex, Nov 14, 2004.

  1. Promanex

    Promanex Registered

    Joined:
    Aug 30, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    i have the code below to make an invision powerboard install via fantastico from anywhere on my site . it makes all the files and stuff but for some reason it only makes a default global_conf.php so the forum wont work :(

    PHP:
    <?php 

    $user
    =$_POST['user'];
    $pass=$_POST['pass'];
    $url=$_POST['url'];
    $request "/frontend/x2/addoncgi/install.html?url=$url&addonname=InvisionBoard&user=$user&apass=$pass&submit=install";
    include(
    "config.php");
    $sock fsockopen($host,$port);
    if(!
    $sock)
    {
    print(
    'Socket error');
    exit();
    }

    $authstr "$ownername:$reseller_pass";

    $pass base64_encode($authstr);

    $in  "GET $request\r\n";

    $in .= "HTTP/1.0\r\n";

    $in .= "Host:$domain\r\n";

    $in .= "Authorization: Basic $pass\r\n";

    $in .= "\r\n";


       
    fputs($sock$in);
       while (!
    feof($sock))  {
    // fgets ($sock,128);
    $result .= fgets ($sock,128);
    }

    fclose$sock );
    echo 
    $result;
    ?>
    does anyone know how to fix this problem? :eek:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice