The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fantastico install errors with latest cp/whm updates

Discussion in 'General Discussion' started by PPNSteve, Nov 1, 2010.

  1. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    We're running the cP/WHM stable tree and with the latest updates it seems to have broken Fantastico.
    whena user tries to install a scrip/app from fantastico, they get this MySQL error:
    Code:
    Install OS Commerce (2/3)
    
    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'jps'@'localhost' (using password: YES) in /tmp/cpanel_phpengine.1288635197.5564ULoG9uwzAd on line 1641
    Access denied for user 'jps'@'localhost' (using password: YES)
    Can anyone help us figure out what's wrong and how to fix it?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  3. PPNSteve

    PPNSteve Well-Known Member

    Joined:
    Mar 13, 2003
    Messages:
    393
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Somewhere in Ilex Forest
    cPanel Access Level:
    Root Administrator
    Twitter:
    No know issues or errors with the above.. it seems is a direct result to how the db users are named and/or permissions granted to the users

    usually fantastico creates a new db / user combo but in this case it fails.

    any other thoughts?
     
  4. dclaw

    dclaw Member
    PartnerNOC

    Joined:
    Aug 24, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Escondido, CA
    Hi,

    I am having the same exact issue. It does not look to be a fantastico problem, as some of my servers are experiencing it, and some are not. All servers are running 11.28.15-CURRENT.

    Thanks for any help,
    Mike
     
  5. anderseriksson

    anderseriksson Registered

    Joined:
    Nov 9, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    we just got the latest whm update installed and have the same issue installing wordpress from within fantastico:

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'usernam'@'localhost' (using password: YES) in /tmp/cpanel_phpengine.1289331582.13396HyW0sAwOHv on line 1641
    Access denied for user 'username'@'localhost' (using password: YES)

    whm build:
    WHM 11.28.27
    CENTOS 5.5 i686 standard on server1

    If anyone have a quick fix we will be eternally grateful :)

    /Anders
     
  6. Stupiddrunk

    Stupiddrunk Registered

    Joined:
    Aug 17, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Exact same problem here with a wordpress installation

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ziebart'@'localhost' (using password: YES) in /tmp/cpanel_phpengine.1289347291.7707CpxfD2CjiR on line 1641
    Access denied for user 'ziebart'@'localhost' (using password: YES)

    it worked yesterday before i updated to 11.28 on this same account
    WHM 11.28.27
    CENTOS 4.8 i686
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've just made sure I'm running the latest CURRENT: 11.28.28 on a server with Fantastico and then installed a WP blog successfully.

    Since I posted those links above several days ago, Netenberg has reorganized its site and I can't come up with any good links to help from there, ATM. But this issue has indeed come up on these very forums.

    One example: http://forums.cpanel.net/f5/errors-fantastico-54187.html
     
  8. Frankc

    Frankc Well-Known Member

    Joined:
    Jun 18, 2005
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    16
    I also have the same problem after the latest WHM update.

    Install phpBB (2/3)

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'oakweb'@'localhost' (using password: YES) in /tmp/cpanel_phpengine.1289977687.97924sqD7SNyTJ on line 1641
    Access denied for user 'oakweb'@'localhost' (using password: YES)

    Anyone found a fix yet please?
     
  9. ReiJu

    ReiJu Well-Known Member

    Joined:
    Mar 14, 2008
    Messages:
    57
    Likes Received:
    1
    Trophy Points:
    6
    Same here, running WHM 11.28.35 and get the exact same error when installing via fantastico. I've even reinstalled fantastico (after upcp --force), but nothing changed. Funny, though, this only happened to some servers, not all of them, despite their similar configs.

    No word from either cpanel or netenberg.
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Kosmo has made these links live again I believe, read only but the FAQ area is back up. Also, Fantastico is not a cPanel product. Has any of you put in a ticket to Fantastico on this issue?
     
  11. hostservicenet

    hostservicenet Registered

    Joined:
    Nov 14, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    We've the same problem after the latest WHM update (WHM 11.28.52).
    ======================================
    Warning: mysql_connect() [function.mysql-connect]: Access denied for
    user 'xxxxx'@'localhost' (using password: YES) in
    /tmp/cpanel_phpengine.1291459088.11530VhsNnRMv7P on line 1641
    Access denied for user 'xxxxx'@'localhost' (using password: YES)
    ======================================
     
  12. hostservicenet

    hostservicenet Registered

    Joined:
    Nov 14, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ticket submitted:
    ======================
    TICKET ID #70 / STATUS: pending
    ======================
     
  13. gurunetwork.net

    gurunetwork.net Registered

    Joined:
    Dec 4, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    To resolve the issue simply log into your cPanel interface click on change pass and reset the password, relog into your cPanel interface and you should be able to access the broken features.

    Feel free to contact me or PM me if you have further problems.

    Leoben
     
  14. oddsmojo

    oddsmojo Registered

    Joined:
    Dec 10, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    The issue is with a mismatched password in mysql. To fix this match the password for the mysql user with the cpanel password.

    Mysql values while issue occurring.


    mysql> select user,password,password('--') from user where user='cpusername';
    +-------+-------------------------------------------+-------------------------------------------+
    | user | password | password('--') |
    +-------+-------------------------------------------+-------------------------------------------+
    | cpusername | *F...F | *9...A |
    | cpusername | *F...F | *9...A |
    +-------+-------------------------------------------+-------------------------------------------+
    2 rows in set (0.00 sec)

    Obvious mismatch. To fix the issue ::


    mysql> update user set password=password('--') where user='cpusername' limit 2;

    mysql> select user,password,password('--') from user where user='cpusername';
    +-------+-------------------------------------------+-------------------------------------------+
    | user | password | password('--') |
    +-------+-------------------------------------------+-------------------------------------------+
    | cpusername | *9...A | *9...A |
    | cpusername | *9...A | *9...A |
    +-------+-------------------------------------------+-------------------------------------------+
    2 rows in set (0.00 sec)

    And now it is matched. This will fix the problem.
     
  15. BuffaloWeb

    BuffaloWeb Well-Known Member

    Joined:
    Jul 1, 2003
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Great, but how to fix this for all users at once? (Short of re-entering a couple hundred passwords manually!)
     
  16. tukaramg

    tukaramg Member

    Joined:
    Sep 22, 2005
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    In order to resolve this issue, you have to login to your cpanel >> change password option and reset the password that you are using for cpanel.
     
  17. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    I have come across a similar issue, but mine appears to be due to password complexity requirements in cpanel.

    Thus, what I found is that fantastico reported a successful WP installation. However, we were seeing the loathed white screen.

    Checking the sql setup revealed that the database user was not assigned to the database. Trying to do so manually with the password in wp-config.php revealed that the user could not be added due to the password not being sufficient complex to meet the requirements enforced via whm/cpanel settings (in this case, only 40% requirement.)

    This would appear to be a Netenberg issue - I do not see any option in Fantastico that would allow complexity requirements to be set.

    Unfortunately, I've found Netenberg support to be horrible.

    Does anybody know of a fix or workaround, other than dumbing down the password complexity requirements in cpanel?

    Thanks.

    Mike
     
  18. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  19. lbeachmike

    lbeachmike Well-Known Member

    Joined:
    Dec 27, 2001
    Messages:
    313
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Long Beach, NY
    cPanel Access Level:
    Root Administrator
    I'm not sure you correctly understood the issue I've described. The issue is that Fantastico is assigning a database user password that does not meet the complexity requirements defined in WHM/cpanel. This means that the database user does not get assigned.

    This has nothing to do with accessing Fantastico or its features.
     
  20. egillette

    egillette Well-Known Member

    Joined:
    Jan 5, 2010
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Orlando, FL
    cPanel Access Level:
    DataCenter Provider
    Ran into the same issue -- it was the password complexity.

    Use a more complex password, or manually adjust the complexity settings for MySQL users in WHM => Password Strength Configuration

    Once you do that, it'll work fine.
     
Loading...

Share This Page